Which frpc file to download to connect moralis server to blockchain

Currently i am working on a web3 project and want to use moralis server for listening my events. But i am not able to download frpc file to connect on windows. It is showing as a threat to windows and it is not letting me download it. please help.
I am currently using windows 10 version.

try to download an older version of frpc

can share with me the exact link for the older version.

you will find it in other similar posts:

ok i will try and let you now if it works.
Thank you bro.

I have the same issue, with the recommended version frp_0.37.0, I also did the latest version.

This is the outcome on my terminal

yarn moralis:sync
yarn run v1.22.17
$ moralis-admin-cli connect-local-devchain --chain hardhat --moralisSubdomain f20hkvzg5vgr.usemoralis.com --frpcPath ./frp/frpc
Starting connection to Hardhat
exec error: Error: Command failed: "./frp/frpc" http -s f20hkvzg5vgr.usemoralis.com:7000 -t HRtGRteCpm -l 8545 -d f20hkvzg5vgr.usemoralis.com
/bin/sh: 1: ./frp/frpc: not found

Done in 1.92s.

that error says that it couldn’t find that path ./frp/frpc

I have the folder correctly still don’t know why it can’t locate it. sigh

try to list the files from current folder, to make sure that they have that specific name, you can also use absolute path if you want

This is how it looks

emeka99@CHUKS:/freecode/nft-marketplace-frontend/frp$ ls
frpc.exe  frpc.ini
emeka99@CHUKS:/freecode/nft-marketplace-frontend/frp$ cd ..
emeka99@CHUKS:/freecode/nft-marketplace-frontend$ ls
README.md   next.config.js  pages              styles
components  node_modules    postcss.config.js  tailwind.config.js
frp         package.json    public             yarn.lock
emeka99@CHUKS:/freecode/nft-marketplace-frontend$ cd frp

it looks like it is named frpc.exe, this is linux or windows or something else?

Thank you so much for your job and always available to help. It’s windows, I downloaded the exact version you recommended 37.0.
I added .exe to my file path and it’s connecting now

1 Like

bro i am having this error

PS E:\web3 projects\NFT Marketplace\nftmarketplace\frpc> frpc.exe -c frpc.ini
frpc.exe : The term 'frpc.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check 
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ frpc.exe -c frpc.ini
+ ~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (frpc.exe:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

Suggestion [3,General]: The command frpc.exe was not found, but does exist in the current location. Windows PowerShell does not load commands from the current location by default. If you trust this command, instead type: ".\frpc.exe". See "get-help about_Command_Precedence" for more details.

Any help on this

check if that file named frpc.exe exists in that folder

Yes it does

i am also doing cd into frpc folder but still not working

try to write only frpc.exe in that folder to see if it works

I started my vs code again and tried it, now it ran. any help on why this is not showing connected on moralis even i am connected with my vs code

try to refresh the admin interface, local devchain has to run

Thanks man for giving your time :slight_smile:
workiing perfectly now…

1 Like

hello @cryptokid
could you help me with this problem:

i am not able to make any progress