Unable to connect hardhat local node to moralis

Hey, I was trying to set up the reverse proxy for my local hardhat node using moralis-admin-cli.
I set up my moralisApiKey and moralisApiSecret in my .env file. When I run this command from the docs,
moralis-admin-cli connect-local-devchain --chain hardhat --frpcPath frp/frpc.exe
I get this error.

Here is my frpc.ini file

  server_addr = udavsy27lego.usemoralis.com
  server_port = 7000
  token = b9IHgCdcDg
  type = http
  local_port = 8545
  custom_domains = udavsy27lego.usemoralis.com

I cross checked the api key, api secret and the moralis subdomain multiple times. Everything is perfect.
I am in Windows 11 and I used frp_0.43.0_windows_amd64.zip for my frpc.exe and frpc.ini files.
I have spent a lot of time on this. A help would mean so much to me thank you!

can you try to run frpc.exe directly with that specific frpc.ini file as parameter?

at first look it seems that it can not execute frpc.exe

I use version frp_0.37.0_windows_amd64.zip in case that it helps

1 Like

THANK YOU SO MUCH MANN!! SO MUCH HOURS OF PAIN you saved me. God bless you
I used frp_0.37.0_windows_amd64.zip and it worked THANK YOU SO MUCH

1 Like