./frpc: Permission denied

When I tried to connect my local hardhat blockchain to moralis LINK I got this error ./frpc: Permission denied. I am on windows and running WLS. I downloaded frp_0.43.0_linux_386.tar.gz and put fprc.exe and fprc. ini in the frp folder. When I was running ./frpc -c frpc.ini from the frp folder I got the error ./frpc: Permission denied. I have also tried to download frp_0.43.0_windows_386.zip and but then I get the error No such file or directory -windows

When i run ls -al in the terminal inside the frp folder I get this drwxr-xr-x 2 root root 4096 Jul 10 07:52 . drwxr-xr-x 11 root root 4096 Jul 9 21:14 .. -rw-r--r-- 1 root root 10190848 Jul 10 07:52 frpc -rw-r--r-- 1 root root 185 Jul 10 07:53 frpc.ini

My frpc.ini

  server_addr = rrkcc19nsony.usemoralis.com
  server_port = 7000
  token = 1iDC54vsoG
  type = http
  local_port = 8545
  custom_domains = rrkcc19nsony.usemoralis.com

try with the version mentioned here (directly in windows, not in WLS):

you have to run the version specific to linux in that WLS environment, not a version specific to windows environment