V1.2.9 WebGL Build not Connecting

I created new empty project and installed 1.2.9 game kit. Wallet connection is working perfectly on Unity Editor with metamask scanning.
Unity version: 2021.3.9f1 apple silicon
Game kit version: 1.2.9
After that, I switched target to WebGL. I changed to moraliswebgl template on Player settings.
So i build webgl and open with chrome. No errors i have. But when i press connect button, connected my metamask wallet. But after connect wallet, there is only black screen. Is this normal?

1 Like

You mentioned it’s a new project, should there be something displayed after connecting the wallet (like a scene)?

When metamask wallet connect on Unity Editor, fireworks going out and wallet adress writes to screen. But, black screen on WebGL build.

What do you mean by fireworks? Are you looking at a tutorial?

Like this:

I tried with v1.2.10 but still same. Please someone help.

What is your Moralis serverUrl that you’re using?


Your server seems fine.

I can connect with that demo scene with game kit version 1.2.10 and Unity editor version 2021.3.4. Could you try an older version like that?

So do i connect with Unity Editor but not with WebGL build. Please, could you try with webgl build?

Yes it works with WebGL build and run in my browser (Edge). Can you try with Unity editor version 2021.3.4? I am using the same MoralisWebGL template for Player settings also and same game kit version you’ve tried (1.2.10).

I tried now. Everything is same like you. Unity 2021.3.4, game kit 1.2.10 and browser (chrome, edge, firefox). But black screen :frowning: Congrulations screen is not opening.

Make sure those browsers are up to date.

Can you please outline the exact steps you do to set up the project (e.g. from game kit .unitypackage), configure WebGL, import the demo/fireworks scene, how you build and run to see if there is something you can/should do differently.

First of all, thanks for answering my questions. I just factory reset my device.
My device: Macbook Air M2 Monterey 12.6
Unity Version: 2021.3.9f1 SILICON LTS
Game kit version: 1.2.10
I created a new empty project and i changed to WebGL. After that, i installed moralisweb3sdk_v1_2_10.unitypackage file to my new empty project.

After that:

Everything looks fine there, thanks for the videos. I will try to replicate this or at least provide the steps I do that works on my end in a new project over the next few days, although I am on Windows.

I guess another option if you’re willing is to try on a different computer or use a VM e.g. Windows to try and run it.

Unity Version: 2021.3.9f1 SILICON LTS

To confirm, you did try with 2021.3.4 before?


1: Create new Unity project (2021.3.4)

2: Open moralisweb3sdk_v1_2_10.unitypackage to import into project (“Import Unity Package”)

3: Add server / dapp URL and app ID in game kit Web3 Setup popup

4: Add demo/wallet scene (Assets > Moralis Web3 Unity SDK > Demos > Resources > Introduction.unity)

5: Copy WebGLTemplate folder (Packages > Moralis Web3 Unity SDK > Resources) using file explorer into project’s Assets folder

6: Build Settings > Platform change to WebGL > Switch Platform

7: Build Settings > Player Settings > WebGL Template change to MoralisWebGL > close dialog/window and reopen to make sure it saved

8: Build Settings > Build and Run > browser

I tried same everything with 2021.3.4 and black screen :frowning:

I’m not sure, can you try on another device? Remember to make sure the server you’re using is up as well, the one you posted at the top of this thread isn’t responsive.

Chrome developer console when black screen open.

That server is a new one? Do you mind sharing the serverUrl and appId to make sure that’s not the issue.