V1.2.9 WebGL Build not Connecting


There is no problem with the server. I even opened a new account and created a completely new server, but the problem persists.

It was working in Unity Editor when I tried it on Mac Os. But it doesn’t work even in Unity Editor on Windows.
Windows 10 64 bit
Unity 2021.3.4f1
Moralis kit 1.2.10

I do not get that issue with your server with the same OS and Unity editor/SDK versions. This is in another new project?

Yes, i created empty new project. But it was working in Unity Editor on MacOS. So the error in Windows does not matter. It is enough if the error in the WEBGL build I created on macOS is resolved :slight_smile:

Black screen problem is still same with v1.2.11. Problem not solved on WebGL Build.

These are the project files from a working WebGL project on my end (default scene) - you can try that.

I tried on Macbook Air with Silicon Arm and black screen problem is still same. But i tried on Macbook Pro with Intel, it working perfectly. Metamask wallet is connecting. I guess, Unity cannot make build right with Macbooks that have silicon arms. Please fix moralis webgl builds for apple silicon version.

Black screen issue persists on Apple Silicon Builds. Wallet link not working. But macbooks with Intel processors do not have such a problem.