useNFTBalances Issue

Hi everyone,

I am using useNFTBalances() hook to get my nft balances in react.
After minted my NFT, I can’t get new nft from useNFTBalances().
But I can get new nft on metamask wallet.
How can I fix?

Here is my code.
const {data: NFTBalances, isLoading} = useNFTBalances();

useEffect(async () => {
console.log(NFTBalances.result); //it returns only old nfts without new one.

}, [NFTBalances]);

Hope your quick help.


Can you help me on this issue?

on what chain is that? there will be a delay until the API will return new data from chain, a number of blocks until it is considered as confirmed

Sure, I waited a few hours.
Still can’t get new nft.
But, I can see history for it on moralis database.

Here is screenshot.

I use BSC testnet

if you test it here in web3api interface, it returns that NFT?

No, it also returns only 2 NFTs without new one.

What’s up?
How can I fix?

maybe it is some problem with the API, can you paste the address and what is nft token that you expect to see there?

my wallet address: 0x458E674dd77A950B08F0962168BA105e814Cd2Cd
nft token address: 0x65aEdf1f09eDB0CB19FbcA5De36Bff063e4E2011

Please help quickly.

we made some changes to the API today and it looks like it is related, we should fix it soon

Okay, thanks.
Please let me know as soon as possible you fix it.
I will look forwards your fixed message.

I don’t know if you will see it today, it is late for me now

It is very urgent issue for me.
Can you help me?
Or if you have any solution, please let me know.
Because our clients knows that I use morails apis, if I don’t have any solution for this issue in a short time, they won’t use moralis apis anymore.
If they disappoint about moralis apis, I think it is bad chance for me and you.

try now, it may work now

Thank you.
It works now for me. :grinning:

it seems it doesn’t work again now.
What’s up?

After minted new nft, I can’t get it via NFTBalances, but, can see them on metamask and BscNFTTransfer table on moralis server.

I tested on your web3 api.
It still returns empty.
token address: 0xbc0bdbba6f590736761901b8348ccfee428a26bc

So, it is your moralis api issue or my issue?

It looks like a problem with the API. We will investigate.

Did you fix the api?
Please let me know after you fixed it.

we didn’t fix it yet on testnets

same here, can’t use getNFTsforContract in mumbai chain, hope moralis team resolve it fast :muscle: