Sync and Watch Contract Events - does not populate table

I am working on syncing events.
Contract is:

I want to track all the transfers. I tried all the variations I could for topic and ABI.

  1. Table will only appear if I restart the server
  2. Table won’t populate with historical nor new events
  3. On a test page I have done listing transfers, calling:
  • Moralis.Web3API.token.getNFTTrades
  • getWalletTokenIdTransfers
    I see in Console log errors (CORS type) on tracking event. Not sure it is related at all

Topic: Transfer(address,address,uint256)
“inputs”: [
“name”: “from”,
“type”: “address”
“name”: “to”,
“type”: “address”
“name”: “tokenId”,
“type”: “uint256”
“name”: “Transfer”,
“type”: “event”

What am I doing wrong. I read the various posts but can’t find an answer.


I can take a look later. I don’t see something obvious at a first look. I’m going to need the server url.

Thank you

The Contract on Etherscan displays this for ABI

You have to copy that exact abi with indexed part too.

It worked correcting ABI with

I had tried that but topic had space characters at the time.

Thank you

1 Like

Crypto Kid, follow up question for you:
Why does getWalletTokenIdTransfers returns only Opensea transfers, knowing the server is able to access full data ?
Is there a similar function allowing me to access the full data ?

I don’t know what is that function. Where from it is?

This also works on other EVM’s which are not on opensea. So it should return the transactions even if it is not on opensea.

Can u share the contract or NFT id for which it did not return transactions.


You should create a separate forum thread for this question

Can you share the document to which you are referring for this?

I am referring to the below one where there is no mention of “only supporting Opensea”

Sorry John, getting confused with the 2 calls. The one that is Opensea specific is getNFTTrades (Moralis.Web3API.token.getNFTTrades) for which I specify the contract not the token.

marketplace (optional): Marketplace from where to get the trades (only opensea is supported at the moment).

Ok I did, thank you