[SOLVED] Help: Speedy node endpoints "Unauthorized"

Yesterday, i passed to pro plan, because i had exceeded the limit of web3 api requests.
The Moralis team had to change my API Key for it to work. And it did. i can now request API request.

But i don’t know if this caused other problems because since, i realised i have another problem.

Using the speedy node endpoints for ETH mainnet, it gives me this answer :
UnhandledPromiseRejectionWarning: Error: Invalid JSON RPC response: "Unauthorized"
This happens on calls that were working before the limitation. I did not change anything on the code i use.
And now half of the requests made with my web3 instance do not pass.
I have now same limitations on web3 websocket.

I think there is a limitation also that occured on my Speedy Node Key.

Please could you verify, or change my Speedy Node Key to be sure there is no limitation anymore.

i did not have problems before, and did not change the code. it all begun starting on when i received an email telling me that i exceeded the limits of requests.

I have a pro plan now. please change my Speedy Node Key.
Thanks in advance.

1 Like

What are you using for the speedy nodes? @Kryptec keep in mind that the speedy nodes is mainly used for deploying smart contract and not to handle huge block query on the blockchain, for that you might be better using one of our Web3 APIs as we indexed those data for you :raised_hands:


Hello, for exemple, getting data from a smartcontract. the queries are small.

I just made a test, changing the node to ALCHEMY, and it worked. that shows that there is a limitation on my Moralis Node key.

I really prefer Moralis services, that’s why i would prefer to solve the blockage, rather than use another provider

Hello @Kryptec, I’ve not given you a fresh new node token. Please try with that one.

Let me know if that helped! :slight_smile:

Hey @kresimir, nice to see you. You helped me yesterday for the web3 api.
Thanks for changing my node key.

I’m gonna try now and get back to you quick.

1 Like

That was it !!! Great, it’s all working now !

Thanks guys. I’m really happy to see such reactivity in Moralis team.

All my respect.
Thanks again :grinning:


any time, dear @Kryptec :slight_smile:

I face same issue right now. Upgraded my account to pro and then get unauthorized exception for many requests on speedy node. I sent mail and chat messages to help bot but i can not receive any response. Please can you help me? Thanks.