[Question]: How to transfer mutliple NFTs in one transfer


Is there a way to transfer multiple ERC1155 NFT’s in one transfer?


In this example only one tokenID is transfered.

Hi have you tried the example below that with the amount parameter?

Transfer NFTs - Moralis

Havent tried it yet, but I dont think the amount is for that purpose. ERC1155 can have multiple amount of one NFT.

So you mean individual ERC1155s?

Yes, I want to transfer multiple ERC1155 tokenIDs.

Are they all from the same collection? I think you can use safeBatchTransferFrom on your contract for this.

Otherwise I think you’ll run into the same issues as bulk transferring ERC721s.

Thank you will give it a go.

Gave it a go with safeBatchTransferFrom and it looks like that is exactly what I want. The issue is that once the transaction is successful, getNFTs moralis function is still returning the NFTS that I no longer own. This is the transaction https://ropsten.etherscan.io/tx/0x3a455e5e8ec0897c201fd9a4a5f8129a29587ec77b6e2d26323f84c1452bca9e

I tried to resyncMetadata but I am still seeing NFTS in my list.

What to do next? Could you guys maybe add this functionality into Moralis, bulk transfer of ERC1155 nfts?

How long has it been in between the transfer and using getNfts? Is it working now?

You can suggest that in https://roadmap.moralis.io, possibly the Moralis functions to transfer linked above will sync this automatically.

It has been at least 20min now and I am still seeing the NFTS in my wallet.

1 Like

Still seeing the NFTS in my wallet.

@alex Still at this time NFT’s are in my wallet. I think there might be a bug here. Also using moralis transfer of nfts looks like it does not update the getNFTs list. Is there something wrong with the synhronization/indexing of NFTs per wallet?

The transfer using moralis code https://ropsten.etherscan.io/tx/0x97e00ff369988343c84176387f9f8cdf51b438b48c9b89a175bd896cfe85f030

Also did a resync of transfers through Moralis dashboard.

syncTransfersNFTs    23 Apr 2022 at 12:57:55 UTC    23 Apr 2022 at 12:57:55 UTC    
Cannot read properties of undefined (reading 'number')

CC @cryptokid, he helped me a lot with my other questions. Thank you guys very much for your time.

1 Like

@cryptokid @alex The issue was resolved by you guys re-indexing the DB but now with a new bulk transfer I see that the NFT’s transferred are still in my address, so it might seem that there is potentially an issue with a handler on transfer.

Is there a function that can be called to resync the NFT’s because the function call from the dashboard is still returning the same error as from the previous post.

In etherscan it works as expected? We had some problems with indexing NFTs in last few days for the web3api results.

Yes, it does look like that etherscan is showing that the transaction was successful.


Ok, this could mean that it is only a problem in the output for web3api. We will work on fixing it in next few days.

Is there something I can do for my server so the issue is fixed now, because now I still see NFTs that I do not own, even those that were transfered using Moralis transfer (transfer happened after bulk transfer).

Where do you see that on your server?

Sorry, I did not use the right words regarding server. I ment if there is something I can do to try and resolve this issue that I have right now? I tried syncTransferNFTs from moralis dashboard but it returned an error.

syncTransfersNFTs    23 Apr 2022 at 12:57:55 UTC    23 Apr 2022 at 12:57:55 UTC    
Cannot read properties of undefined (reading 'number')

Not sure though if this function is only executed on the mainnet or even on testnets.

Where on server you expect to see something, in what table? Also, you have a nitro server with coresercices plugin or a non nitro server?