opensea_getOrder plugin error 'network' is not present

Hello Dev Team @cryptokid ! I have been working on a DAPP for some days using the moralis frame work and it has been amazing so far, However when I have been stock at the opensea_getOrders plugin for a while now.
when ever i request a get order i do get this error and my network is clearly defined as “mainnet” and i even went as far as creating a new testnet server implementing the opensea_plugin on it to try out testnet and i still get the same issue. I would appreciate all the help i can get to adequately get my NFTs order

“data”:[{“code”:400001,“message”:“The parameter network is not present”}]

can you share the code that you use?

I am assuming that you use latest version of opensea plugin and also latest version of Moralis SDK

Ok. Thanks for reaching out, here is the code i use

I don’t get that error with that particular code.

did you add in opensea plugin configuration the RPC url for the speedy node for mainnet network?

@Cryptokid I have the opensea_plugin installed on my moralis server, with the mainnet and rinkeby speedy noded configured on the plugin. i went as fear as creating a seperate testnet server to try the moralis plugin in my codde but it keeps returning a Post xhr 400 error as shown in the screenshot below

Can you paste the server url?

I did get an error too, but not that particular error.

@cryptokid here is the server url I am using on my DApp 2053/

It looks like you opened that url directly in browser when you get that specific error message with the network.

There is an error originally that you can see it in the network tab in browser for the original request, it is one of this type: API Error 403: Unauthorized..

I don’t know yet how this error can be fixed.

hi @cryptokid ryprokid this is the error i het when i run the code in the react function i sent in the first screenshot of my IDE. Const getOrder = async =()=>{…}

it shows the parameter network is not valid and i have that setout in my code

what you get if you run this: console.log(Moralis.CoreManager.get("VERSION"))?

I used vanilla js in my tests

i am using React
give me a sec to try this

@cryptokid I get js1.6.0 when i run console.log(Moralis.CoreManager.get(“VERSION”))

ok, strange, I have js1.7.0, what you get should be close to up to date

can you look in browser network tab to see what it was sent to the server as payload when it got that error?

@cryptokid the payload sent is still a POST request.

POST: //https: serverUrl/_useMoralisaFunction_opensea_getOrder error 400

@cryptokid i upgraded my moralis js to 1.7.0 and restarted the DAPP, and ran the getOrder function again here is the payload error i got again.
Request URL:

Anh here is the header response of the network section

for now that request will not work, at least it doesn’t work in my case either, I just get a different error message

can you try to get an OpenSea API key?

I heard that is hard to get

that is also what I heard until I also heard that:

@cryptokid is there a way i can get the specific price of an NFT id without using the getLowest price function cause it does return adequate information on a particular NFT price.
i tried the getNFT trade but dont know how to loop through the object array to search for the token Id i want to retrieve its specific information