Images not showing on Opensea

I’ve deployed the following contract on remix/rinkeby.

contract NFT is ERC1155 {

    using SafeMath for uint256;

    constructor() ERC1155("ipfs://QmdjEa88oz6eFhGP52AHfH6cvgGx3A8o5nktbwsNVczpe9/metadata/{id} .json") {

        _mint(msg.sender, 0, 1, "");

        _mint(msg.sender, 1, 1, "");

        _mint(msg.sender, 2, 1, "");



The token_uri and other parameters are correct but the image and metadata is not visible on open sea.

Link to Opensea

Could someone please point out if I’m missing anything? I’ve waited for long but it’s still not visible.

Link to JSON

You can try refreshing the metadata on opensea. It’s working fine as shown on rarible

Hi @qudusayo, It’s been more than 24 hours now. Even after refreshing the metadata multiple times, it’s not working.

is that space intentional?

nvm, it looks like there is no space in the contract:

can you try with a contract that uses
instead of

as in ipfs://QmdjEa88oz6eFhGP52AHfH6cvgGx3A8o5nktbwsNVczpe9/metadata/1.json

It doesn’t make sense, but you can try.

Hi @cryptokid,
Tried that as well. Doesn’t show up on Opensea, but visible properly on Rarible. Also followed a tutorial from Moralis. Seems like even that’s not working.

Can someone try to create a sample contract and confirm if it’s working?


You can also read this similar thread:

Have you tried redeploying - everything looks fine from your end. As for your contract code, is this just an example? As your contract has tokens 1, 2, 3, and not 0, 1, 2.