EthNftOwners, EthNftOwnersPending not updating any more

Hi team,

I am running ganache locally and have deployed my contract to it. I have also connected it to Moralis and the Devchain Proxy Server status is connected.

Previously when i would mint an NFT via my app, the ‘EthNftOwnersPending’ and ‘EthNftOwners’ would be updated automatically which was amazing.

However, it is no longer working.

Locally i can see that i am successfully minting the NFTs and the ganache is working as expected.

I can also see the users deatilas get added to the database as expected after signing in.

For some reasons EthNftOwners, EthNftOwnersPending do not update!

I have tried restarting Ganache, i have tried restarting the Devchain Proxy Server connection. I have also tried restarting the Moralis server instance.

There are also no errors in the log message so i am lost atm. What else can i try. @Yomoo

I think that when you sign in it will be a direct connection to Moralis server using Moralis SDK, without looking on what is in local ganache.

yep that is my understanding too. I am just pointing out other things the server does seem to be working fine.

If you do some transactions in ganache, will those get into Moralis dashboard like in EthTransactions table?

Usually, we would wait for a number of blocks to completely transfer the ownership (So that orphan blocks do not affect the ownership in the real ethereum/bsc/polygon network). Since this is a local blockchain, every transaction is a single block, so execute some extra transactions to see if the EthNftOwners, EthNftOwnersPending start updating.

I executed a large number of transactions to increase the block number and still no change. In the end i just created a completely new server instance and connected that to my app and everything is working again as expected, first time.

This makes me think there is some sort of error/bug that i can’t see with the original Moralis server. I’ll leave that server online so the devs can have a look at it if they want.

Please share your server url so that devs can check it. Thanks.

You can try latest version of Moralis Server now (0.0.259) to see if the problem was fixed.

1 Like

I will try it and let you know. Thanks

@cryptokid the issue is still there and now i know how to replicate it.

If i create a new server instance and connect up with ganache locally and deploy a smart contract for the first time, everything works perfectly and as expected.

However if i need to change my smart contract and i redeploy the smart contract locally, Moralis seems to stop picking up any local blockchain activity.

Perhaps i’m doing something wrong or unexpected when i am redeploying the contract locally?

1 Like

Events my not sync if you redeploy the contract without updating the contract in sync events because it requires the contract address.
What you do when you redeploy a smart contract?
As a workaround I’m thinking that you could try to delete the server instance and create a new one before redeploying a smart contract to see if it works this way.

Creating a new server instance is a working work around but its very annoying as i need to pre populate data into the new database for my app to work.

When i redeploy the contract i run the following commands on truffle

truffle networks --clean
truffle migrate --reset --network develop

Is it actual server domain?

Please check this one

sorry did i misunderstand your question?

You got it right :raised_hands:

1 Like


I see that transactions are registered, so updates in the datable should work. But I also see you have some afterSave triggers

shouldMintExcalibur does it work correctly?