Ethereum unity boilerplate

Hello, I don’t understand this part… Unity is a bit complicated. I’m only familiar with unreal engine

If the Wallet Connect property is set to “None” drag WalletConnect from the “Hierarchy” section to this input.

2 Likes

The “Hierarchy” section is the panel that shows the scene elements.
image
When you click on this the detail of the panel will be displayed in the Inspector Panel.


In this image the Wallet Connect property is set to Wallet Connect (Wallet Connect) which should be the default. If this were set to “None” you would drag the WalletConnect GameObject from the Hierarchy Panel into this field:

Please let me know if this helps.

Regards,

David

Ohh great great tomorrow I will practice it thanks!!

1 Like

Hello friend, now gives me this error and does not log with the wallet … I already scanned it, and I already changed it to metamask. In the menu

1 Like

Those messages are not errors - just part of the instruction log.

The first shows that the PLAY method in MainMenuScript was executed (the user clicked on the “Authenticate button”).

The second shows the user is not logged in, indicating the login sequence should execute.Was the QR Code shown to you?

Hello. Thanks for replying… If that’s the qr I showed the game but doesn’t connect with the wallet. Do not call to sign… :thinking:

The default is to run in desktop mode. Did you scan the QR Code with your mobile wallet?

Yes with the mobile wallet
:open_mouth::thinking:

Sorry taking so long. Double checking with a few other people …

It may have been something with Wallet Connect. We were havng the same issue. It appears to be working now. I am now able to authenticate again. Please try now and let me know if it works or not for you.

, It doesn’t work yet, I don’t know what it can be
:pensive::thinking:

Are you seeing an error in the wallet? Would youmind posting the logs from the time you click the authentic button until the time the error shows?

guys finally manage to install unity on vscode, testing it now. btw what are the command keys to move the hero, it keeps going to sleep on the ground , lol

1 Like

@m33lucky,

The correct keys are W or S. In combination with SHIFT the character will run instead of walk. You can also use the arrow keys.

I need to disable the A and D keys, the controller does not implement anything for them so the current logic defaults to the final animation which is DIE :slight_smile: You may have also noticed that nothing happens when you attack.

Hope everything else is working as expected.

Regards,

David

1 Like

Thanks for the info I will retry soon

1 Like

Hi, i’m having compile errors mostly from namespace. I’ve already linked VS community 2019 to Unity. v1.0.0 of the boilerplate works fine but v1.0.1 won’t run. Pic related. Any idea how to solve this? Many thanks.

1 Like

@Kamille,

Are you still having this issue?
Under Asstes->MoralisWeb3ApiSdk->Moralis.Web3Api.Core->Models find the file named NftTransfer.cs. Look at the “using” statement section at the top of the file. Is there a syntax error where it reads “using Newtonsoft.Json;” (around line 6)? If so Unity is not able to find the Newtonsoft library. Please let me know.
Also which version of Unity 3D is your project built under?

Thank you,

David

Hi David, thanks for the reply. Yes there is a syntax error newtonsoft.json is not a recognized library. I tried updating all the unity instances, but to no avail. Also tried installing this newtonsoft package (https://github.com/jilleJr/Newtonsoft.Json-for-Unity#readme) but got more errors. I’m using VS community 2019 and Unity editor 2020.3.19f1. The installeed packages i have currently is as image below. Any idea what i’m doing wrong here? because version 1.0.0 worked for me if i manually put moralis sdk the files into unity instead of using the unity package.

1 Like