Ethereum React Native Boilerplate Questions

If you are using the Ethereum React Native Boilerplate use this thread in case you have questions!

1 Like

In my case I could not make yarn android work. I’m also not familiar with it so no idea what the problem could be, the command prompt simply doesn’t continue once the list of addresses with 1000ETH are shown, no meesage, no error. Maybe you could run yarn android in one of your future videos to see the expected behavior.

1 Like

what doesn’t work?

do you see some errors?
does the app not load?

Hi @fourtimesperday,

Looks like android start has an extra configuration to be made to start the application. I will gather more info and let you know ASAP.

This is all I see:

1 Like

What’s the command you used? yarn android ?

Yes yes yes yes yes yes <-(20 char limit)

@fourtimesperday,

I’m looking at the issue right now. If this is a legit issue, I’ll push the fix asap. OR if it’s just a config issue, I’ll lay down the steps over here and in the ReadMe file as well.

Thank you for your patience. :pray:

yarn web:

TypeError: moralis_react_native__WEBPACK_IMPORTED_MODULE_3___default.a.setAsyncStorage is not a function

import Moralis from “moralis/react-native.js”;
Adding “.js” solved the issue
But.

Hello,
I used this this boilerplate, I was able to run it successfully with out any error.
When i click on Crypto Auth/login button in android app, i faced some issue.

  1. Click on Button does not show WalletConnect Modal to select provider.
  2. On Button click, it showed open in browser option only if metamask is not installed.
  3. If metamask is installed and i click on metamask, it open metamask but show 404 Wallet Connect Page then auto redirect to Login page of WalletConnect, I am attaching screenshots here.

I’m on a windows machine. Cloned the boilerplate and run the app both on an emulator and a physical device , both are stuck on the splash screen

Can you post your error details from console/terminal?

That’s the funny thing , there’s no issue in the console. there’s no error, it’s just stuck on the splash screen for who knows why

It seems to be an issue with expo. And expo has this weird problem where it doesn’t show the error. We are still investigating it. I can assure you though, it works on IOS.

Alright , will be waiting

I’m not sure if this will solve the problem

I have tried this too bust still didn’t work for me

Please I need help

What issue do you have exactly? Please post exact error

1 Like