Deep Index Errors: 520, 502


I’ve been using the deep index api with varying levels of success without changes to my request… sometimes it works, other times it doesn’t. I’m not sure what is causing this. I have a Pro plan.

Trying this request with Insomnia results in a 520, then a 502.

I tried many other configurations, same result.

Sometimes, I receive an unknown error, and in the raw response of that error, I see that data was partially streamed before the request died and failed as a whole. I dont believe its a timeout issue since my timeout setting is at 15mins and these requests take less than 10 seconds to fail.

@cryptokid following up here from our conversation on discord

I tried a new set of credentials from a different account and the same requests that failed, worked once. Then it started giving me 520 statuses as well…

I’m testing now to see if I can reproduce that error

I tried this request 3-4 times in web3api interface (

and I didn’t get an error now

Could it be that rate limiting is causing this to happen? Maybe i’m getting banned by cloudflare. My service sends a lot of requests, but with outgoing throttling applied. So for my account, it rarely gets more than 4 rate limit exceeded responses for payloads of over 200 requests. And when that does happen, it applies a cooldown before re-trying.

None of it makes sense because it works Sometimes. But recently, all of my requests don’t give a response. The request gets aborted.

I believe my issue is directly related to this one REST API Errors

Yes, it seems like it is same issue as in the other thread. Is shouldn’t be related to rate limit. There should be a specific error for rate limit

Hi all, seems im having similar problems. I had pipelines running that used moralis and worked before but as of today they are failing but occasionally they work. I found out that they are 502 errors and the majority of times i get ChunkedEncodingError: ("Connection broken: InvalidChunkLength(got length b’’, 0 bytes read) using python requests. Does anyone have a similar issue as well?

1 Like

I’m also having new issues. Using aiohttp in Python - until today has been working great to get owners of ERC-1155 on Polygon: ```

Perhaps of interest, the web3Api page allows that to work BUT it first hits Chrome with a "do you want to wait or continue" message.

we don’t know yet in what conditions this happens, it looks like an intermittent error

I don’t know how to reproduce it yet

For me (linked topic REST API Errors) the error is as follow:

cURL error 18: transfer closed with outstanding read data remaining (see for


A file transfer was shorter or larger than expected. This happens when the server first reports an expected transfer size, and then delivers data that does not match the previously given size.

If you DM me, I’ll send you my API key to test with. My pro account is currently for testing. I dont have any data in Moralis. I just use it for node access.

I don’t think that the api key is the problem in this case

Was there any change in your API response headers configuration recently? @cryptokid @ivan
Most of my jobs stopped working properly so it’s a big blocker for me .

Thanks for your time guys

I don’t know of any change in API response headers configuration

can you try to make the requests from a different location to see if there is a difference?

I tested it with another network and it worked properly so I’m pretty sure it’s on cloudflare side then. Same as @shrimplypibbles, I do a lot of calls and I suspect my IP to be banned from. When we do a lot of calls we should face rate limiting errors from Moralis but not be blocked by Cloudflare…

Is it possible to be whitelisted again?

if the IP would be banned, then you could not do any call in a specific time interval

anyway, send me the IP din DM

I believe I’m experiencing this. I haven’t been able to make a call since this thread was posted.

what error do you get?

For the logs endpoint, I get unknown error or request aborted.

For erc20 metadata, sometimes empty response. Ex: