Could not detect network in BSC mainnet speedy node

Hi! I have the same issues like thats:

Half month ago it worked correctly
Plz help me!

do you get a specific error? can you try to use the speedy node url for a simple request, for example to get latest block number?

Yes, I have such error

  reason: 'could not detect network',
  code: 'NETWORK_ERROR',
  event: 'noNetwork'

my code is the same as in topics I pined

I have error just with your nodes
So for example I don’t have such errors with wss:// that BSC documentaion provides

I wanted to ask if the node doesn’t work in general for any command, or in particular only with that?

we can reset the speedy node token if you send me in DM your email and current speedy node token

I think it doesn’t work for any command. So how to send you DM ?

I still got same error, how to fix it?

what do you do to get that error?

I’m using to interact with smart contract, one hours ago it worked. Then i try to use new moralis token it work again

Hi, i’m getting this error;

Uncaught (in promise) Error: could not detect network (event=“noNetwork”, code=NETWORK_ERROR, version=providers/5.6.0)

what is the code that you use when you get that error?

I got the same error on the Moralis.executeFunction call, what should I do?

speedy nodes were discontinued yesterday for free plans, maybe it is related

ok and how to solve this?

you can use a different RPC url in your metamask config

the paywall slowly rises :grin: