Connecting ganache to moralis server

Hi and wish you all a happy new year!
I try to connect ganache to moralis server. I use linux mint 20.2 cinnamon. I did all, I downloaded frp, I succeeded to copy from “Devchain Proxy Server” both [common] and [ganache] and replace into frpc.ini and save them, then I went to command with “readlink -f” and see please attached.

It is not remaining in folder (I guess) therefore the run command “./frpc -c frpc.ini” is not working.
Please help, what i need to do?

when you execute ./frpc you should be in the folder where frpc is found, I don’t know what are the contents of the directory where that command was executed

Thanks for reply.
The content of directory is the frp
It is used for connecting ganache with moralis server.
See please my previous attached picture, it is running out of folder and I don’t know how to do to keep it in place and after, to apply . /frpc

I don’t understand what it is going on in the above picture.
Can you run there ls -al to see what are the contents of current folder?

Have you extracted the files from the tar file?

From your picture, you are not in the frpc folder and this one does not exist, so maybe you just need to extract all files from the frp_0.38.0_linux_mips64.tar.gz file.

Carlos Z

Guys, i run ls -al and attached the picture.
I also extracted files from the tar please see attached picture.
Finally i run the readlink -f [folder address] and I got nothing.

My goal is to have it stable on my command line so that i can apply the ./frpc
Thanks a lot!

what does that readlink command?

how is that you don’t do a cd in the folder where frpc is located?

I just did it now, see please the screenshot, thank you!

you may need to un archive that archive, you said that you modified the ini somewhere, the path that you tried there ends with .tar.gz that doesn’t correspond to a folder usually and to an archive file

Man thank you you were right, my bad :frowning: I applied right and I am half way, problem when I add the ./frpc -c frpc.ini from Moralis “Devchain Proxy Server” it did not happen, see picture. Please advice further!

now it looks like it expects a different type of executable file, maybe you need to download frpc for another platform and not for mips64

I tried “frpc/” it is not working, see picture. and he ask me to install with cmd “sudo apt install
Can you please advice if this is the one I need? Thx!

it depends on your system architecture, the docker options seems to be more complicated

when you download frpc, you have multiple options, what other options that include linux do you see there?

Hi, after I search a lot I did not found other than the mentioned in Moralis “Devchain Proxy Server” namely “./frpc -c frpc.ini” for linux and “frpc.exe -c frpc.ini” for Windows. I found advice to use “nohub” cmd and see picture what I got. Kindly can anybody advice me?

where from did you download frpc, there are multiple archives there to download from, every archive is specific to an operating system and platform. I think that you need to download an archive specific to your platform and not mips platform.

I downloaded the “frp_0.38.0_linux_mips64.tar.gz” and Yes, multiple choices - but not for RUN command “./frpc -c frpc.ini” - not found!
Unfortunately the RUN “./frpc -c frpc.ini” for linux mentioned by Moralis in “Devchain Proxy Server” it is not working.
On the net I could found only instructions
Kindly if you know any website from where I can find and try to use a workable frpc run command, thank you again!

how is that you chose that particular mips64 architecture? what architecture is your system? what does mips mean?

mips was a safety choice… was wrong probably so there are 4 more choices:
Which of them to try?

it depends on your hardware, amd64.tar.gz may work or 386.tar.gz

I tried all 4 available, all are sending me successfully into the file, when I apply ./frpc -c frpc.ini command, 2 are calling connection error and 2 are giving error, see attached all 4 pictures.

What you think? Thank you!