Wss Binance Speedy node gets stuck when i run truffle migrate to deploy on Binance testnet

hello guys, i have an issue
im trying to deploy a contract to binance testnet and i use moralis Binance speedy nodes
if i use HTTP and truffle i will get timeout, so i went with Wss and it was great, but lately when i try to truffle migrate to binance testnet using wss node, the terminal gets stuck after compiling the code and it freezes,
any help ?

You could try with another RPC node too to see if it works, like directly from Binance

yeah public RPC nodes are working but (not always) thats why my company went with moralis

also i tried it today and it worked but after 4 tries
and it got bugged again and after couple of tries it works

there are 2 speedy node urls, one for historical and one for non historical, you tried them both?

right now some different issue raised when i try to deploy using websocket rpc for binance testnet

Error: Unexpected server response: 429

that looks like a rate limiting error code

is it an issue with the wss binance testnet node ?

how can i solve it

No it means you are being rate limited, means you have used up your plan’s quota

to have more, need to upgrade your plan

thank you for answer, how can i upgrade my plan

@kresimir can help you do that :raised_hands:

you can also send an email to [email protected]

1 Like

thank you Yosephks

should i message him directly or he will join this chat ?

thank you so much

thank you
its been sent via email

1 Like