Websocket connection get closed with 4290

I use websocket connection to monitor pending transactions, and each time connection closes with 4290 code. I moved to paid plan - but the problem still exists. How can it be fixed?

Is that a rate limit error?

It looks so. 4290 code

How many pending transactions can you read until fretting that error?

Tested recently, got 4290 error code after 5015 calls to getTransaction(hash)

There may be a limit of 5000 requests per minute that you hit

But how can I increase this limit? I have already moved to paid plan. I dont need web3 api, only speed node. Is it possible to disable api rate and instead boost request rate?

Hey @terryprogetto

You can optimize your code to make lower number of requests or upgrade it to custom plan. Also please share your node link in DM