WebGL. Wallet authorization does not work (Unity)

When I build a WebGL build and try to access the wallet, I get this error. The same error occurs if the build of your demo scene is built. I think this is a problem in some additional plugins that I use. I strongly suspect FMOD. Can he somehow influence Moralis?

Or maybe it’s a different problem? Does anyone have any ideas?

Hexroast Web.loader.js:1 exception thrown: TypeError: Cannot read properties of undefined (reading ‘connect’),TypeError: Cannot read properties of undefined (reading ‘connect’)


Did it work before FMOD? I saw your other thread, which error is the current one?

There are a lot of plugins in the project and Moralis was the last one added. In the beginning there were problems with PUN 2, but they were solved. The WebGL project was launched, but the connection to the wallet did not work, throwing out these errors. The same reaction to the Moralis demo scene. If I click the authentication button, the application was stuck with these errors. After consulting with colleagues, we decided that it could be because of FMOD, and I added Moralis and PUN 2 to the empty project. The WebGL build worked well. Having decided to add FMOD to this project, I got a computer freeze when configuring this plugin. After a reboot, the project with Moralis, PUN 2 and FMOD Unity simply does not open. So the question arises whether the presence of these plugins can break the integrity of the Unity project?

did you find a solution by now?

There is no adequate solution, because at some point everything worked. I won’t even say exactly what helped, because I reinstalled everything)