Web3Auth (Web2 Login Method) + Moralis

Hi everyone, I recently implemented the Web3Auth Authentication and I’m having some issues when the user is connected via web2 login (Gmail, Facebook, Twitter, etc.).

Any writing transactions within the smart contract show an error, I can even call a read-only function.

What’s the error shown ?

This error does not happen if I’m logged in via crypto wallet.

You can try to mint an Item using the two login methods with Web3Auth and you will see only with the crypto wallet works perfectly.

Link: https://development.dwriterss.io


I emulated here a user logging in the application and trying to mint an item. You will see that the first one (web3auth - web2 method (Gmail)) does not work for some reason and the second one (web3auth - web3 method (crypto wallet)) works perfectly.

Could be an issue with your contract or some difference between MetaMask and the Web3Auth provider. Also try a transaction on another function on your contract.

I wasn’t able to test your site as I couldn’t get past the readable NFT file check with any PDFs I had.

Transactions (doing a contract deposit) work fine on my end on Mumbai with the built-in wallet. Only problem is that it didn’t require me to sign any transactions (I guess it’s ok because it’s more an onboarding/casual wallet).

Was able to do some test writing to a contract using web3 auth on the binance smart chain testnet and everything worked fine with with no issue. Here’s the example I used https://web3auth-bsc-ex.surge.sh/.

Maybe you can debug further to see if you can get more info about the error. You should also consider what @alex mentioned

1 Like

Guys, now it is working and I didn’t change anything on my end. I also messaged Web3Auth yesterday regarding this problem, and probably they did something on their end.


@alex can you please let me know what error you had when you were uploading a PDF file?

Great, possibly it was just a network issue.

For one PDF I use, it gives me an error of Something went wrong, Please, fill in all fields correctly. and I can’t submit, another PDF brings gives me an immediate The file format you are trying to upload is not acceptable. And then another epub file gives me the first Something went wrong, Please, fill in all fields correctly.

1 Like

Probably you forgot some of the fields, maybe the tags… you gotta press enter to add your tags (we will improve that.)

I added one tag. File error would be related to the PDF, no? Language is also not selectable.

Looking good otherwise though, nice work.

1 Like

Thanks @alex, I will make sure to correct these glitches!
We have an event next week with more than 38K people in Toronto to introduce our project. This is why I’m constantly bugging you guys. In the meantime I fix that, could you help me figure out why the OnRamper is not working? I’ve tried several times with my wallet and it’s just not going through

In the meantime I fix that, could you help me figure out why the OnRamper is not working?

You can make a new thread with what you’ve done in code, any errors, etc.

1 Like

Hey @alex, I’m trying to reproduce this error here but without success.
Can you share the file you are using with me?

Please let me know what environment you are using.

It happens on the development version you linked but the form submits fine on main.

1 Like