Web3Auth.io x Moralis: "@web3auth/web3auth" not installed, please install

Hi, noob in need of help here. I’m following the Web3Auth.io integration guide in Moralis docs (youtube video included).
Done all the steps required but when the autheticate function runs it responds with following error:

Authentication Failed!
@web3auth/web3auth” not installed, please install

Can somebody help me find out what am I missing?
Thanks in advance.

can you take a good read at this

you are going to install it like this
yarn add @web3auth/web3auth

Hi @0xprof, thanks for the reply. I installed it using:

npm install --save @web3auth/web3auth

but getting the error anyway. Suggestions?

can you see it in nodemodules ?
can you see it in package.json ?
can you import it into your code?
can you use yarn to install it again ?

Yes, I can see it in nodemodules
Yes, I can see it in package.json
Yes, I can import it (only warning : 'web3Auth' is defined but never used no-unused-vars
Yes, crated brand new test react app using yarn
Still same error appears.
Thanks for helping

check this out

Hi, any progress? I’m getting same issue. Installed, checked version and package.json

Successfully connecting metamask and magicLink with similar method, not sure what the issue is with web3auth connection though

hi @chad125, unfortunately not. Further steps I’ve done:

  • following @0xprof suggestion, from Web3Auth GitHub, Installd even @web3Auth/Base dependency
  • set up a different PC with node.js 17 on Win11 (in original pc I had node.js stable 16 with Win10) and followed again al steps from Moralis Web3Auth tutorial, including additional dependecies from GitHub

Still same error pops up at runtime. Any help is really appreciated.

1 Like

id say maybe it could be a problem on the moralis side if so many ppl seem sto be having issues with this. i can ask one of the devs. @cryptokid do you know if there is an issue on moralis side with the web3auth login flow

you try to run that from nodejs or from a browser?

Yarn start from terminal and test it on Chrome v99 on localhost:3000

you want to get rid of the error or to make it work?
you use react?

also, I guess that you have latest version of Moralis SDK

I would like to make it work. Yes, the app has been created with yarn create-react-app test and all Moralis dependecies added with yarn add moralis react--moralis (that should add the latest version, if I understood right).
Thank you very much for your help, btw.

Hello, i will create a simple login with web3auth following the docs to test this :thinking: (reproduce)
and see what the actual problem is ?

There is no -- in react-moralis, idk if this was a mistake here, it should be yarn add moralis react-moralis

Hello, i ran a test and i made a dapp with login for moralis x web3auth and it seems to be working alright , i followed the docs and the tutorial and everything seem to be working and i got no errors, just a quick note, you do not import web3Auth into the code, but you do install the package
check the test site (https://moralisweb3authtest.netlify.app/) and the code is in the site, but here it is (https://github.com/0xPr0f/web3auth), you can also clone and then yarn and build off the project, i only created a react app (webpack 4) and i integrated the login following the docs

1 Like

@B.One, make sure to make an account here and get the publishable clientId too.

Typo, my damned fat fingers. Thanks for pointinig that out

Thank you very much: I’ll go through it and will update here. First note: I’ve always used webpack 5. I’ll try with webpack 4 following your footsteps and check if webpack version has any role in this.

Hi @qudusayo, thanks for helping. Yes, I’ve already created a Web3Auth.io account and configured it.

1 Like