Web3 user sign in data is undefined

Hey Moralis,

We recently implemented this code to retrieve users data when signing in to the Metamask account. It worked during the first time of implementation. However, without any changes to the code, it currently cannot perform those actions. Here is the code, please take a look.

Previously, users details are recorded once signed in through Metamask.

Furthermore, the deactivate function did not work the second time.

Overall issue:

  1. Users details are not recorded when signed in.
  2. The deactivate function is not working.

We would really hope someone could help us with this. Thank you.

I donโ€™t understand exactly what is the problem, do you see errors in your browser console?

I cant upload more than two embedded images. This is the rest of the code to retrieve users information and replacing them in the user data.

The issue at the moment is when we sign in through metamask, the Moralis server does not reflect the users details. The entries in the column created are undefined. Here is the image of the column.

Previously, the code worked fine the other day. Therefore, we cant seem to understand why it does not work now.

It might be related to the deactivate function as the current button does not deactivate after its connected to metamask.

Hey Cryptokid,

Weโ€™ve tried creating a new server and it worked perfectly fine. We are not sure why the existing server did not work. Could it be the server slept when we go idle?

It would be a concern of ours if we need to keep creating new servers.

if server would not be available, you should see some error in the console, and also in the admin panel you will see if the server is sleeping

We checked the web console and there wasnโ€™t an error. Interestingly enough we created several test accounts, 6 to be precise and 3 of those accounts were able to input the details. However, 3 of them remain undefined. No clue why. Here is the screenshot.