Web3 NFT Shop Forum

Lets use this thread to support each other with questions regarding the Web3 NFT Shop Project :star_struck:

Course Link: https://academy.moralis.io/courses/in-game-nft-shop

Feel free to ask for help here - but also ensure YOU HELP people that are asking questions you know the answers to

The Moralis staff and community managers will be keeping an eye on this too :star_struck:

1 Like

Hello All, In this project when I buy the nft it will through me an error in debug label that “Transaction failed” and I’m still struggling to solve this but could not find a solution yet,if someone know the problem and had ever solve this then please response me at here, Thank you!

1 Like

Hi @shahrooz, have you deployed the smart contract and configured ContractAddress and ContractAbi like showed in the video? Is this happening just after following the whole video or have you made some modificaton?


yeah, I had deployed as it was in the video But now what’s the problem with it.
I’m trying to figure it out and I’m sure that, I had gone entirely through with the video.

Before continuing, welcome to the community @shahrooz :slight_smile:

Sorry for late replying, could you solve this? For what I see in the image, it looks like a problem while contacting with the contract so make sure you copied the right ABI, formatted well, and also the right contract address. Also remember you need to have the mumbai testnet imported in your MetaMask mobile wallet.

Update me on your process,



1 Like


I got this error after then transaction failed message popup on screen.I followed every step from deploy contract and address to ipfs data in database but still got the same error.

Thanks in advance

Hi @bugBee88 and welcome the Moralis Unity community :slight_smile:

This looks like the same problem as @shahrooz was having. It looks like an issue while contacting with the contract so make sure you got the right ABI and formatted it. When copying it from Remix, make sure that NftShop.sol is selected. Are you using MetaMask with mumbai testnet imported?


1 Like

Thank you for the response :slight_smile:

Yes mumbai tesnet is imported correctly and Abi is formatted correctly still i got the same error.

Thanks in advance

Hi I resolved that issue now i get into another error after buy the nft it will be visible on opensea testnet but when i open the player inventory panel i got an exception error

Thanks in advance

Hi @bugBee88! Glad it was resolved. If I may ask, what was causing the issue?

About the next one you’re posting, I’ll try to replicate and get back to you tomorrow.


1 Like

I was pasting wrong ABI that caused the issue :sweat_smile: but when I open player inventory panel I get this error.

What is the error? It seems you posted the wrong image.

Hi this is the problem that I am facing.

NFT’s are minted successfully on opensea and it is removed from database as well but when I open player inventory to check which NFT’s I own i go this error.


Hi @bugBee88
As i search on google for the error mentioned by you, Variables in .NET are either reference types or value types. Value types are primitives such as integers and booleans or structures (and can be identified because they inherit from System.ValueType).

Check out this link: https://stackoverflow.com/questions/779091/what-does-object-reference-not-set-to-an-instance-of-an-object-mean

Hi @bugBee88,

I couldn’t replicate the issue last week. Everything is working fine on my end. But I’m now working on my next project which will include also this functionality, so I’ll be testing this further. I’ll let you know if I can replicate.


Hello, which moralis sdk version was used for this project? im getting errors with moralis 1.2.0 package

Instead of adding some items how can I show the nfts which are present in my wallet…?

It would likely be 1.1.0 as 1.2.0 was not released at the time of the video.

You can use getNFTs API. And then show them in the same way as the shop code/tutorial does.

Hi everyone, does this project support WebGL ?
When I try to build and run it shows this error