WatchEthAddress is no longer getting historical info

Hey there, so I’ve returned to my project after some time to find that watchEthAddress and watchBscAddress no longer seem to be syncing history for the specific address.

When I call this, the address is added to the table as expected but no history is added in.

I can confirm though that any new transactions that the address performs is added as required.

I have also upgraded my server to the latest.

I have tried calling the function from both the front end, and inside cloud code itself with the same result every time.

Maybe I’m just being impatient, but I’ve been waiting for over 10 min, and no historical transactions have been added for eth or bsc.

Thanks for your time.


Also, I noticed that the “WatchedEthAddress” and “WatchedBscAddress” are no longer generating a balance on create, and I also remember that they would have a “scyncing” field when they were created, neither of these seem to be happening also.


I understand the issue.

Can you also post your server subdomain so that we can investigate further?

Thank you for your patience. :slightly_smiling_face:


Hope you’re doing well.

Could you show us the implementation that you used to call the watchEthAddress function. Ideally, you would need to add the "sync_historical":true in the request parameter.

If you’re using the plugin UI to add the watch address, you will get a checkbox to add syncing. Please find the below screenshot for the same –

Do let me know if it worked out for you. :slight_smile:

1 Like

Hey Malik

Thankyou, this is exactly what I needed. Everything working as expected after adding sync_historical. Definitely a hard one to find in the documentation.


1 Like

Keep up the great work. :raised_hands: