Watch cloud install not working in IDE

Execute the watch-cloud-folder and change to the correct path of your cloud file

I seem to be having trouble executing the watch cloud file path. I’m positioned in the folder where cloud_functions.js is but I keep getting the same error message when i input the path.

I’ve watched Nikolas’s video on executing, but the file path is different in hos video. Can you anybody help ?

This is the cloud file i get from the server
moralis-admin-cli watch-cloud-folder --moralisApiKey Z96bkZtDC9lt7vw --moralisApiSecret SNnemqxn37uADDI --moralisSubdomain --autoSave 1 --moralisCloudfolder /path/to/cloud/folder

This is the path i put in
Adams-MacBook-Pro:rarible-clone adamsheridan$ moralis-admin-cli watch-cloud-folder --moralisApiKey Z96bkZtDC9lt7vw --moralisApiSecret SNnemqxn37uADDI --moralisSubdomain --autoSave 1 --file ./cloud_functions.js
Specify path to cloud functions folder: /Users/adamsheridan/Downloads/youtube-tutorials-main/rarible-clone/cloud_functions.js

This is the error message I get

Tried it a bunch of times and i have installed cli globally.

Hi @ad01LA

Please be careful with publishing your private account info.

In the console, you can read the reason for the error. Are you trying to add an empty file?

I’ve copied the file from the cloud functions modal in my server.
Please could you show me what a correct file path could look like in my ide ?

Hey @ad01LA

Take a look at:

UPD: Take a look at the tutorial how to use watch-cloud-folder

Hey @ad01LA

Check this out: Set up Cloud Functions in your IDE Step 2: code example out of date with changes