WalletConnect issues (removing connections, removing token approvals))

Hi, I have an issue with trying to remove connections from WalletConnect. Recently I learned about token approvals on etherscan so I decided to use it via the internal browser of TrustWallet. It connected successfully via WalletConnect and showed I have two token approvals. The first I was interested to remove was an approval for Uniswap V3 Positions. The ‘remove’ button didn’t work as it told me: “Connect to the owner’s address to remove”. So I went to the Uniswap link via the browser and connected. I returned back and tried the “remove” button again. It didn’t work.
Then I decided to try Chrome. I visited Etherscan and attempted the same procedure as before: it showed me a popup in which it gave me some information and there was a REMOVE button to click. However, clicking on it didn’t actually do anything.
Further, after refreshing the page couple of times, clearing caches and disconnecting, I no longer can even connect through WalletConnect. I went in the Settings menu and tried to disconnect the existing WalletConnect sessions one by one. When I click the “Remove Connection” button, it just doesn’t do anything. My guess is the sessions are stale, but I can’t remove them.

TrustWallet app version: 8.13.1

Let me know if you need further information to tackle this issue.


1 Like

Hi @ivan.zanev

I would recommend reporting this to the respective wallet support. We cant be of much help here.