User project is inactive

I got this error in this morning.

My app not inactive: got 401

Why I got this error?

that error seems to be specific to a rpc url, maybe. you have some browser extensions enabled?

what extensions enables?

I donโ€™t know what extensions you have enabled in our browser, it depends on your browser

ok thank bro, let me check.

I checked, test on new PC, new browser still got same error.

what url you are accessing first time when you get that error?

if you access google you get same error?

I got this error when login via Google Web3auth.

Everything is ok still last step Moralis couldnโ€™t logged. I check storage open login_store is ok but site not login.

Still not login

maybe it is related to web3auth then, maybe that is a RPC url used by web3auth

you could try to update the web3auth package, or try to use a custom RPC url, or both

I donโ€™t know why it would not work with google auth

you are using moralis v1 or moralis v2?

I using V1 self-host.
how to custom RPC in Moralis authenticate

My code

await authenticate({
        provider: 'web3Auth',
        clientId: process.env.NEXT_PUBLIC_API_KEY_WEB3AUTH,
        chainId: process.env.NEXT_PUBLIC_MAIN_NET_CHAINID,
        appLogo: process.env.NEXT_PUBLIC_URL + '/logo.png',
        uxMode: 'popup',
        whiteLabel: {
          name: 'Lofi Game',
          logoLight: process.env.NEXT_PUBLIC_URL + '/logo.png',
          logoDark: process.env.NEXT_PUBLIC_URL + '/logo.png',
          defaultLanguage: 'en',
          dark: true, // whether to enable dark mode. defaultValue: false
          theme: '#D72F7A',
        signingMessage: message,
        throwOnError: true,
1 Like

what is 1.9.0 version?

a version of moralis sdk, if you have a newer version than that version then it should be ok

upgrade 1.11.0 to 1.9.0 ?

no, 1.11.0 is newer than 1.9.0

My version is OK. I can custom RPCTarget in authenticate function ?

Yes, that syntax to set a custom RPC url should work for you

1 Like