Upgrading to V1 of react-moralis with WalletConnect breaks the app

When we upgrade the npm package of react-moralis to V1, we see these errors when trying to launch our app:
Module build failed: Error: ENOENT: no such file or directory, open ‘/Users/shahar/Projects/gallerium/frontend/node_modules/@walletconnect/http-connection/node_modules/eventemitter3/index.js’

We tried to just remove the @walletconnect/web3-provider package as I know you guys are moving to ether, but then running the app brings this error in build time:
Module not found: Can’t resolve ‘@walletconnect/web3-provider’ in ‘/Users/shahar/Projects/gallerium/frontend/node_modules/moralis/lib/browser/Web3Connector’

So basically, it seems that trying to run V1 with wallet connect is broken.
Anything we are missing or should we just downgrade back to the latest version before V1?

it may be better to post in this thread: Moralis JS SDK v1.0 (migration to Ethers.js)

Thanks. Will do. Sorry about that.

Do you use walletconnect in your app? If not, then you might see a warning Can’t resolve ‘@walletconnect/web3-provider’,(this has been a known issue for a while and we are working on a better solution), but your app should still build. If your app does not build, then there might be another error. Is this the case?

I tried making an app, with and without the @walletconnect/web3-provider packages and in both instances I can build the app.

Do you have more info, to let me reproduce this error?

  • Do you have other errors as well?
  • What packages are you using (and what versions), mainly regarding moralis, react-moralis, and walletconnect
  • Do you use a framework? Like next.js, create-react-app etc.? (and what version?)

Can you try if it works with moralis v1.0.4?
We just released a fix

Thx! I’m in meetings but will try to update again in a few hours and will let you know.

I just updated to 1.0.7 and things seem to work fine. Thx!