Unauthorised 401 return from Rest API

I’ve wasted enough time on this, so it’s over to an expert! Please?

I’m using my own backend executable program & want to access the Web3 APIs but no go.

My ‘Web3 API Key’ is placed in the request Header using:
‘X-API-KEY:’ (as shown in a doc somewhere)

The Get statement is:
Fetch ('https://speedy-nodes-nyc.moralis.io/310d42f0bca4a543ff35a800/bsc/mainnet/transaction/0x173e0f3b427c40ad121f90129b48f97cf8697e11c33127947ccaa99f5bd89c49')

All I get from this is:
HTTP/1.1 401 Unauthorized
Date: Tue, 07 Dec 2021 09:46:47 GMT
Content-Type: text/plain
Content-Length: 12
Connection: keep-alive
CF-Cache-Status: DYNAMIC
Expect-CT: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
Server: cloudflare
CF-RAY: 6b9cd42b8fc255a5-SYD


Do I need to be logged into Moralis or complete some Auth code first?
It should be as simple as APIs with sites like Coinmarketcap or Binance, but no.
Any light on the subject is appreciated thanks.

you can try api calls here with that X-API-KEY: https://admin.moralis.io/web3Api

what are you doing there looks more like a request to a speedy node

Yeah, that got something, but it’s an html doc with this in it:

=“Build Serverless web3 apps without having to worry about backend infrastructure”>Moralis Admin</

No BSC transaction that I asked for.

I tried numerous different syntax but couldn’t get a result, so I went over to BscScan & tried their API & bang, worked first time. Bye