TX fee on polygon Speedy node

Hi, i’m using polygon node and when I use high gas price, node respond “tx fee (1.27 ether) exceeds the configured cap (1.00 ether)”.

Looking on geth docs, I found a command to change this: “–rpc.txfeecap value : Sets a cap on transaction fee (in ether) that can be sent via the RPC APIs (0 = no cap) (default: 1)” (https://geth.ethereum.org/docs/interface/command-line-options)

It’s possible to change this option on polygon node?


Might want to check here : https://docs.ethers.io/v5/api/providers/provider/#Provider--transaction-methods

I think by now you cant set the tx fee cap for the speedy node, so might be worth to try by web3

Carlos Z