Transaction Count intermittently wrong

I have a process that reads the transaction count of a given address every 500m. I noticed that using a non-archive speedy node (BSC Mainnet), the count returned is flickering by 1 through the process. I created a small script that compares the count returned by Moralis speedy node vs RPC from Binance.

I started the app and got that results


there are multiple nodes behind a load balancer

but when did that address make the last transaction (489), how long ago before you started that script?

wayyy before I executed the code… I ran the same code but instead of getting the transaction count, I was getting the block number and bellow the results… See how the block numbers are going up and down… I also got one way older then the others (12921674).


“there are multiple nodes behind a load balancer”

ohhhh ok that might be the “issue”…

do you still get that way older block number now?

It only happened when I executed that one execution… I usually get small +/- 1-2 blocks differences.