There are too many requests queued on Cloudflare's edge that are awaiting process by your origin web server

I’m experience the same issue (rate limited) mentioned here: "Too many requests for speedy-nodes-nyc.moralis.io. Try again later."

Here’s what I’m seeing in my server logs.

missing revert data in call exception(error = {
        "reason": "bad response",
        "code": "SERVER_ERROR",
        "status": 503,
        "headers": {
            "date": "Wed, 06 Oct 2021 14:47:37 GMT",
            "content-type": "text/html; charset=UTF-8",
            "transfer-encoding": "chunked",
            "connection": "close",
            "x-frame-options": "SAMEORIGIN",
            "referrer-policy": "same-origin",
            "cache-control": "private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0",
            "expires": "Thu, 01 Jan 1970 00:00:01 GMT",
            "cf-ray": "699faf9a5b33efd8-EWR",
            "server": "cloudflare"
        },
        "body": "<!DOCTYPE html>\n<!--[if lt IE 7]> <html class=\"no-js ie6 oldie\" lang=\"en-US\"> <![endif]-->\n<!--[if IE 7]>    <html class=\"no-js ie7 oldie\" lang=\"en-US\"> <![endif]-->\n<!--[if IE 8]>    <html class=\"no-js ie8 oldie\" lang=\"en-US\"> <![endif]-->\n<!--[if gt IE 8]><!--> <html class=\"no-js\" lang=\"en-US\"> <!--<![endif]-->\n<head>\n<title>Rate Limited</title>\n<meta charset=\"UTF-8\" />\n<meta http-equiv=\"Content-Type\" content=\"text/html; charset=UTF-8\" />\n<meta http-equiv=\"X-UA-Compatible\" content=\"IE=Edge,chrome=1\" />\n<meta name=\"robots\" content=\"noindex, nofollow\" />\n<meta name=\"viewport\" content=\"width=device-width,initial-scale=1\" />\n<link rel=\"stylesheet\" id=\"cf_styles-css\" href=\"/cdn-cgi/styles/main.css\" type=\"text/css\" media=\"screen,projection\" />\n\n\n<script defer src=\"https://api.radar.cloudflare.com/beacon.js\"></script>\n</head>\n<body>\n  <div id=\"cf-wrapper\">\n    <div class=\"cf-alert cf-alert-error cf-cookie-error hidden\" id=\"cookie-alert\" data-translate=\"enable_cookies\">Please enable cookies.</div>\n    <div id=\"cf-error-details\" class=\"p-0\">\n      <header class=\"mx-auto pt-10 lg:pt-6 lg:px-8 w-240 lg:w-full mb-15 antialiased\">\n         <h1 class=\"inline-block md:block mr-2 md:mb-2 font-light text-60 md:text-3xl text-black-dark leading-tight\">\n           <span data-translate=\"error\">Error</span>\n           <span>1200</span>\n         </h1>\n         <span class=\"inline-block md:block heading-ray-id font-mono text-15 lg:text-sm lg:leading-relaxed\">Ray ID: 699faf9a5b33efd8 &bull;</span>\n         <span class=\"inline-block md:block heading-ray-id font-mono text-15 lg:text-sm lg:leading-relaxed\">2021-10-06 14:47:37 UTC</span>\n        <h2 class=\"text-gray-600 leading-1.3 text-3xl lg:text-2xl font-light\">This website has been temporarily rate limited</h2>\n      </header>\n\n      <section class=\"w-240 lg:w-full mx-auto mb-8 lg:px-8\">\n          <div id=\"what-happened-section\" class=\"w-1/2 md:w-full\">\n            <h2 class=\"text-3xl leading-tight font-normal mb-4 text-black-dark antialiased\" data-translate=\"what_happened\">What happened?</h2>\n            <p>Too many requests for speedy-nodes-nyc.moralis.io. Try again later.</p>\n            \n              <p>Please see <a rel=\"noopener noreferrer\" href=\"https://support.cloudflare.com/hc/en-us/articles/360029779472#h_302a97f3-eba3-4c0a-a589-76ba95f60dcf\" target=\"_blank\">https://support.cloudflare.com/hc/en-us/articles/360029779472#h_302a97f3-eba3-4c0a-a589-76ba95f60dcf</a> for more details.</p>\n            \n          </div>\n\n          \n      </section>\n\n      <div class=\"cf-error-footer cf-wrapper w-240 lg:w-full py-10 sm:py-4 sm:px-8 mx-auto text-center sm:text-left border-solid border-0 border-t border-gray-300\">\n  <p class=\"text-13\">\n    <span class=\"cf-footer-item sm:block sm:mb-1\">Cloudflare Ray ID: <strong class=\"font-semibold\">699faf9a5b33efd8</strong></span>\n    <span class=\"cf-footer-separator sm:hidden\">&bull;</span>\n    <span class=\"cf-footer-item sm:block sm:mb-1\"><span>Your IP</span>: 64.225.11.13</span>\n    <span class=\"cf-footer-separator sm:hidden\">&bull;</span>\n    <span class=\"cf-footer-item sm:block sm:mb-1\"><span>Performance &amp; security by</span> <a rel=\"noopener noreferrer\" href=\"https://www.cloudflare.com/5xx-error-landing\" id=\"brand_link\" target=\"_blank\">Cloudflare</a></span>\n    \n  </p>\n</div><!-- /.error-footer -->\n\n\n    </div><!-- /#cf-error-details -->\n  </div><!-- /#cf-wrapper -->\n\n  <script type=\"text/javascript\">\n  window._cf_translation = {};\n  \n  \n</script>\n\n</body>\n</html>\n\n",
        "requestBody": "{\"method\":\"eth_call\",\"params\":[{\"to\":\"0xb2c6c4162c0d2b6963c62a9133331b4d0359aa34\",\"data\":\"0x21f8a721436861696e000000000000000000000000000000000000000000000000000000\"},\"latest\"],\"id\":232337,\"jsonrpc\":\"2.0\"}",
        "requestMethod": "POST",
        "url": "https://speedy-nodes-nyc.moralis.io/myAPIkey/bsc/mainnet"
    }, data = "0x", code = CALL_EXCEPTION, version = providers / 5.4.4)
1 Like

Also been experiencing this issue as of last night. I haven’t changed my usage much at all and last I checked I was well under the limit anyway.

Looks like the error has gone away for now.

2 Likes

Spoke too soon. This error started appearing again this morning.

This is the formatted error message being sent back.

Yup still getting this. For some reason it only happens when I use my metamask wallet/HDWalletProvider to make a new Web3 instance but not when i just use Web3.providers.HttpProvider(endpoint).

@Keith, you still get that error?

Yes, I’m seeing it about every 2-60 secs in the logs on my validator node.

is it better than 1 hour ago? there were some improvements done since 1 hour ago

1 Like

At the moment, I’m not seeing the errors. :crossed_fingers:

@cryptokid the error is back again.

It is still a problem now? how bad it was/is?

@cryptokid this error is appearing again. At the moment it’s happening every 2-20 secs.

ok, we will check probably tomorrow morning

@cryptokid just letting you know I’m still seeing the errors. They’re not quite as frequent at the moment, but I’m guessing it has to do with how much traffic the Moralis node is processing at a given time.

1 Like

@Keith, we tried another improvement, it is better now?

Possibly. Last error was 15 minutes ago. I’ll continue to monitor. Thanks!