Syncing Contract Events Error


I am trying to sync my contract events with moralis, but whenever I submit a sync event it throws an empty error. I have ganache working on my computer and the server is connected to the proxy with frp.

The table gets created, but there are no entries inside it. No entries are put into the database when I create new events.

Can somebody help me if they have experienced this issue?

Here is the log:

did you reuse your Moralis Server with another instance of local ganache?
in that case you should create a new Moralis Server.

Thank you for your fast reply! I do not think so, but you might be able to give me more clarification on the situation I will explain below.

I just spun up a new server and created a new sync event, but it still throws that empty error. I reuse my blockchain transactions with these parameters ganache-cli -p 7545 --network-id=5777 -e 10000 --deterministic --db ~/.ganache/blockchain-data. Would that be the problem? Should I startup ganache with no old transactions?

You could try without that load, just to see that it works. I don’t know how that would be a problem.

Same error on a new ganache instance and a new server.

New Moralis server with new ganache instance doesn’t work? User transactions get synced?

Yeah, the transactions sync. But I cannot get event syncing to work.

I tried to create a new fresh instance of ganache and a new server. Authenticating worked, but when I had to create a transaction MetaMask threw an error about the nonce mismatch.

So I removed the network, added it again, reset my account, and then I tried to sync again and got the same empty error (perhaps this errors for old events history syncing), but this time it is syncing when I create new events.

I do not know what the difference was, because I tried with 4 new fresh ganache and server instances and it didn’t work. But doing the extra steps in MetaMask did the job :man_shrugging:

Thank you for helping me cryptokid!