Synch historical failed due to validation failed

I created a server and selected to synch a contract address and an event.

In the dashboard logs it shows

2022-01-04T12:50:15.310Z - Error: Validation failed. Master key is required to complete this request.
    at resolveError (/moralis-server/lib/triggers.js:629:12)
    at /moralis-server/lib/triggers.js:658:21
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)

Anything I missed to setup?

Edit: After removing all syncs and adding a new contract sync in the Dashboard under jobs it says status failed with the error message Address is required

I think that it was a recent addition that master key

But there is no option to add the master key in the server configuration under view details-> Sync

Edit: Trying to restart and update now. Maybe it’ll help :pray: (but created the server like an hour ago)

Edit2: Still the same error

Edit3: Is there a way to downgrade to version 0.0.322? That one worked perfectly for me.

I don’t know yet how to use it, I don’t know of a way to downgrade the server version.

Do you have a link where I can see how to create these syncs programmatically? :thinking:

Maybe I can provide the master key there. Seems like a bug in the upgrade if I’m not mistaken.

Edit: The event synch seems to work, that’s good enough for my urgent requirements. Will just hope that the bscAddress synch works again in the next upgrade :pray:

What works and what doesn’t work now?

synching events works

synching contract addresses does not work

Ok, got it, I was expecting for sync event to work.

1 Like

I am getting similar error in the logs when using my app.

Nothing was changed in the codebase for the past week so I assume its a error on Moralis side.

Could you check if you introduced any bugs when updating the triggers code?

It is related to an update on Moralis side

1 Like

Let us know here if you have any further updates…

Thanks

1 Like

@Shine, @qzi, the problem with watch address should be fixed now in latest server version

1 Like

I can confirm this looks fixed for me after an Update and Restart. Thanks @cryptokid

1 Like