Successfully created relation is empty on DB

I’m trying to have a one-to-many relationship, where posts have several comments and the comments have a reference to their post.

Both tables have all permissions open.

On the Comments table, there’s just an undefined Post column
On the Post table, there’s a Relation column that when expanded, is just empty.

Am I missing something? I’m following along the documentation

Just to be clear, there’s no error being shown in the client.

Try a hard refresh on the page

Nope, nothing

Is there any requirement for the objects passed to the relation.add( ) besides them having their objectId?

I don’t know exactly how it works to add it from code. You can search on google how to do it with parse server too. You can try to add it from interface too, but there you will need to hard refresh the page few times to see the result.

Did you get any error?

Just tried that as well.

  1. Double click on the Post Id
  2. Opens a submenu with input fields for all columns of the post
  3. Found the one for Relation and clicked ‘Select comments’
  4. That opens up a pop-up with a table to pick comments to select
  5. I pick them all/a few/just one but nothing happens

I don’t get the small notification on the bottom-right of the screen that the Post has been updated - the one that does show up when I edit any other field

Edit: Directly opening the relation (clicking on the little green arrow in the relation column) shows an empty table. When I try ‘Add a Row’ does literally nothing, not feedback at all that I just clicked a button

Edit2: Huh, I tried creating a new role (_Role table) and adding users to it but I’m having the same issue, I can’t seem to create a relation between tablets

It is possible to do it. But you have to hard refresh the page after you click a button. It is a bug we have to fix in the interface.

1 Like

Oh. You have to reload directly on the relation page. Yep, manually adding it does work