[SOLVED] Unable to start FRPC

I am trying to start a local dev chain so that i can deploy my contract locally and interact with it.
But i am unable to do that.I copied the hardhat configuration from the dashboard and copy it in frpc.ini but when i try to run the script it fails.

./frpc -c frpc.ini

``
> bash: ./frpc: cannot execute binary file: Exec format error

Okay i guess i had to take a different file other than arm64. Now i am able to run freebsd_386 version. but now it say

./frpc -c frpc.ini
Segmentation fault (core dumped)

I tried it with another frp_0.37.1_linux_386.tar.gz 8.08 MB and it has started but the connection keeps on getting refused.

2021/10/05 14:30:33 [E] [proxy.go:797] [a6d19ee7128346ee] [hardhat] connect to local service [127.0.0.1:8545] error: dial tcp 127.0.0.1:8545: connect: connection refused

Hey @zimablue

./frpc: cannot execute binary file: Exec format error - means that you run not supported version by your system.

Make sure you edited frpc.ini like in server settings:

[common]
  server_addr = xxxxxx.moralishost.com
  server_port = 7000
  token = xxxxxxx
[hardhat]
  type = http
  local_port = 8545
  custom_domains = xxxxxxx.moralishost.com

Yeah i got it working it was just the wrong version of the package which i was trying to run and i did’nt started hardhat node.

1 Like

Great job!

Happy BUIDLing :man_factory_worker:

1 Like