[SOLVED] Unable to get proper NFT Balances through Native APIs of Moralis

Code Looks like this

const {
  } = useNFTBalances();

useEffect(() => {
    if (address) {
      getNFTBalances({params: {address: address}});
    // eslint-disable-next-line react-hooks/exhaustive-deps
  }, [address]);

The results are zero even though NFT exists and can be seen in polyscan

does it work directly in docs page?

I think I’m having the same problem, where since yesterday none of the NFTs I mint are synced and returned when I call the API. I tried calling the API directly from the docs numerous time and I get the same result. And its not only with the getNFTBalances endpoint. Calling getTokenIdMetadata directly also doesn’t return any metadata even though I can clearly see them on polyscan(Using Mumbai Testnet). Waiting doesn’t help. The NFT’s are not visible even after hours. The endpoints just return {"code":141,"error":"No metadata found! Try again later"}. It seems like the endpoints are very out of sync.

1 Like

It looks like the same issue as in another thread. On what chain it happens?

Polygon mumbai testnet

also this issue is with moralis v1

Can you give an exact example that doesn’t work?

As I have given the code above in the topic, I am trying to get NFT balances of a particular address on polygon mumbai testnet. The result of that is empty. Although we can see the NFTs on polyscan

I understand that it doesn’t work. It could help an example of nft that it is missing.

In my case all the NFTs are not showing up for new accounts on my application, but for older accounts it is showing existing NFTs but not showing the newly minted NFTs

This happens also today? For new minted nfts to not show? I mean for new minted nfts today.

This issue is persistant from past 2 days for me

Tried today as well issue remained the same for me

Can you send an example of contract form today that doesn’t work?

Here is the minting transaction

Wallet -

NFT Contract

thanks, that should be enough, we will have to check

1 Like

Any progress on this issue?

It should be fixed now. You can try to run syncNFTContract if it is still not working.

1 Like

This has been resolved thank you

1 Like