[SOLVED] Trouble setting up vanilla javascript boilderplate

Hey I’m super new the Moralis, and have been having a hard time following the tutorials, nothing was really working until I was watching the 6 hour video on the introduction and was mentioned I needed to put an SDK into my visual studio code project. So I went to the documentation he was showing and copied exactly the vanilla javascript index.html code and main.js code. Set up my moralis server, copied in the id and url, and ran it locally using the live server extension. I also got the metamask chrome extension. but it still doesn’t seem to be connecting. I’m completely lost as what to do, setting up trying to understand what’s going on and just following along with Moralis has been a nightmare and uphill battle for the past couple of days.

Thanks in advance
Here is a screenshot of the error in the console.

Can we see your code where you’ve put in your server details as well as your browser running your app. Usually these errors mean there’s an issue with the server connection e.g. the server isn’t awake.

The server url and id were copied from my moralis database info, idk what the security is like with sharing that info which is why I’ve covered it up

I got the template from here


Everything seems fine (although your serverUrl seems a lot longer than appId can you check this), can you try another server? It is fine to expose these two.

ahhhh I found the issue, when copying the new serverUrl I went to double click to select the entire thing and it didn’t select the https: so that just doubled up, so focused on looking everywhere else and being new I didn’t even notice it. Thanks again for your help with this. It’s working now