[SOLVED] Smart Contract Sync not working/not shown

I can see syncs in devTools, but not at the UI, also no tables created

sync object: { "chainId": "0x1", "address": "0x0f71b8de197a1c84d31de0f1fa7926c365f052b3", "tableName": "Etharcona", "topic": "Transfer(from,to,value)", "abi": { "inputs": [ { "indexed": true, "name": "from", "type": "address" }, { "indexed": true, "name": "to", "type": "address" }, { "indexed": false, "name": "value", "type": "uint256" } ], "name": "Transfer", "type": "event" }, "filter": "", "sync_historical": true, "description": "arcona_eth" }

this is not a valid topic, you have to add there the type of the parameter, not the name of the parameter

can you past contract address and chain?

did you also try in the legacy interface?

I have tried with legacy, but at that time i used wrong topic. You can check the chain and contract address in the first message

ok, can you also paste the server url that you used?


can you check again now to see what you see in the dashboard interface?

It Works now, thanks

1 Like

is it possible to sync only tx which are made/received by users in db?

we donโ€™t have that option, you can sync all the transactions for all the contracts for specific wallet addresses (watch address), add filter to an event sync with specific addresses, but not in particular what you are asking