[SOLVED] Moralis admin Cli not working

I have been trying to connect moralis to my local dev chain but it’s not working. Following Patrick’s tutorial on freecodecamp, I have downloaded recommended zip file for windows even linux. I turned off my firewall but still get the same error. I downloaded all necessary docs and copied the hardhat config. Please someone help me.

These are the errors I get on my terminal:

./frpc -c frpc.ini

-bash: ./frpc: cannot execute binary file: Exec format error

[email protected]:/freecode/nft-marketplace-frontend/frp$ frpc.exe -c frpc.ini

frpc.exe: command not found

[email protected]:/freecode/nft-marketplace-frontend/frp$ yarn global add moralis-admin-cli
yarn global v1.22.17
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...

success Installed "[email protected]" with binaries:
      - moralis-admin-cli
Done in 58.94s.
[email protected]:/freecode/nft-marketplace-frontend/frp$ moralis-admin-cli
moralis-admin-cli: command not found

try to run it with npx moralis-admin-cli

Thanks man…npx worked. have been struggling to fix it for 24hrs now.

1 Like