[Solved] FRPC proxy not relaying contract calls to local dev chain


So I recently moved, and previously the FRPC proxy would be properly detected by Moralis and would forward custom contract calls to my local dev chain, easy-peasy, worked as advertised, but since moving (and changing internet providers) the contract calls fail, but login-auth with moralis is working still.

My new location is using Xfinity Comcast (I personally hate comcast and suspect that this new ISP service I’m using is blocking the proxy).

I am using truffle and I boot up a local dev chain using “truffle develop” from the linux command line (not the ganache UI tool).

I followed the instructions and copypasta’d the frpc.ini contents that Moralis provides into my local frpc.ini file, though I edited the port to use 9545 since that is what my local dev blockchain is running on. I have the Chain ID set to 1337.

In the Moralis dashboard for my server, I can see the proxy status is set to “connected” meaning that at some level Moralis can see the proxy service.

However when I try and make custom contract calls to my contract nothing goes through. I did a contract call using the terminal to verify that the dev blockchain is working locally, and those transactions go through.

I tried setting my IP as a whitelisted address for the database access, and that didn’t help.

Is this a “port-forwarding” issue with the comcast wireless router? Or is the issue somewhere else?

I’ve tried everything I can think of and none of it has worked to solve my issue. Please help.

Did you try to reset the local dev chain from that admin interface?

It doesn’t work on a new Moralis server either?

Yes, I tried resetting the local server from Moralis.

No, I have not tried from a new Moralis server, I will try that in a little while and see if that fixes the issue.

Update: I tried making a brand new moralis dapp server instance (using the localDev option), and updated my client side code to use the new credential set. Updated the frpc.ini file to use the new credentials too. I tried resetting the local dev chain from the moralis admin dashboard, I tried resetting the proxy, and still nothing.

It doesn’t allow calls to my local dev blockchain, but in the Moralis dashboard, Moralis shows my proxy as “connected”. And the proxy service shows that it is connected from the terminal on my side. Contract calls are not working at all.

Okay, I feel like an idiot, but I figured out the issue:

Even though I haven’t changed the contract, I did get a new computer and I had assumed that the contract would compile to the same chain address.

When I double checked, and compared the stored address in my code to the address on my development chain, the two were different, and when I updated the contract address in my code and tried again, it is now working.

Uggh, I feel dumb, sorry to have wasted your time, but thanks for trying to help me, much appreciated.