[SOLVED] Etherscan transaction type and Moralis do not match

Hello, I send a request on this URL “https://deep-index.moralis.io/api/v2/0xEf2Ee0bde0e21c3878Ad2F74880d23763e9fD32b/erc20/transfers?chain=eth&limit=250
I get a response and I go to “https://etherscan.io/address/0xEf2Ee0bde0e21c3878Ad2F74880d23763e9fD32b#tokentxns” and they don’t match.

Moralis gives me transactions that are sorted by date in a shuffle on the «Transactions» tab in etherscan and on the «Erc20 Token Txns» tab. Why then request type split into “/{address}/erc20/transfers” and “/{address}”? If “/{address}/erc20/transfers” get from “/{address}” + erc20 transaction.

This transaction is found in both places.

    {
      "transaction_hash": "0x7f2ead5c9ceb82c79118a10423fe9de49afc6f5b98d09defcea24dd50aa8d701",
      "address": "0x6b3595068778dd592e39a122f4f5a5cf09c90fe2",
      "block_timestamp": "2021-09-06T11:45:05.000Z",
      "block_number": "13171969",
      "block_hash": "0x50512aafa135a62102bed9e8bb4e3ffc6ae3b73e0ad9241256d1dc9fdd8e77a8",
      "to_address": "0x795065dcc9f64b5614c407a6efdc400da6221fb0",
      "from_address": "0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b",
      "value": "218059994536729272379"
    },

It looks like they don’t match because etherscan doesn’t include all ERC20 transactions, and only from some ERC20 tokens.

What you wanted to say on the second part I don’t understand. Can you reformulate that part?

2 Likes

Thanks for the answer. I checked again and realized that moralis returns ERC 20 and ERC 721 transactions when requesting the link “/{address}/erc20/transfers”. In this regard, I have a problem. After receiving transactions, I want to make 2 requests for “/erc20/metadata” and “/erc20/{address}/price” as I expect that from “/{address}/erc20/transfers” only transactions with tokens, not with NTF. But now, I need to additionally filter NFT from tokens.

Why not make “/{address}/erc20/transfers” return only transactions with tokens, and “/{address}/nft/transfers” only with NFT. Or am I missing something?

Hm it shouldn’t return erc721 - we need to look at this issue closer
Can you provide

  1. Exact Request you are making
  2. The erc721 you receive in the response that shoudnt be there

Thanks!

First
https://deep-index.moralis.io/api/v2/0xEf2Ee0bde0e21c3878Ad2F74880d23763e9fD32b/erc20/transfers?chain=eth&limit=2
Answer: {“total”:609,“page”:0,“page_size”:“2”,“result”:[{“transaction_hash”:“0xe25bcce85dbd6bb511d370f34f5bbe9d248a62ee966db9bde347f3ea230774ad”,“address”:“0x90ca8a3eb2574f937f514749ce619fdcca187d45”,“block_timestamp”:“2021-09-08T07:42:22.000Z”,“block_number”:“13183800”,“block_hash”:“0x38453b7ec2fa79beb267d19873f4429709d4a7357e80c0b24f2b33d0a16ba8e3”,“to_address”:“0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b”,“from_address”:“0x95d112432c9a1422926f78c7ec12a1bff55b936c”,“value”:“0”},{“transaction_hash”:“0x2d3e23d1d8d04fac050e48dab2bf57fbce518dec581f455e01ff56cd75bccc3f”,“address”:“0x90ca8a3eb2574f937f514749ce619fdcca187d45”,“block_timestamp”:“2021-09-08T07:40:53.000Z”,“block_number”:“13183797”,“block_hash”:“0x0b00ae5cd1a7d549430ae508dd85a9468f40dc7d29d4cd7718b60324ac0ab389”,“to_address”:“0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b”,“from_address”:“0x428252dd6358d36c8d0f7f6cab4d123ebe15015d”,“value”:“0”}]}

0xe25bcce85dbd6bb511d370f34f5bbe9d248a62ee966db9bde347f3ea230774ad and 0x2d3e23d1d8d04fac050e48dab2bf57fbce518dec581f455e01ff56cd75bccc3f transactions, from the JSON it follows that they have the direction INCOMING “to_address”: “0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b”. Go to etherscan in the “Erc721 Token Txns” tab https://etherscan.io/address/0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b#tokentxnsErc721. We see the same transactions with the direction of INCOMING (screenshot)

1 Like

Thanks for the report, seems like a bug, we are on it

And see “htt ps://etherscan .io/tokentxns?a=0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b” total 307 + "
“htt ps://etherscan .io/tokentxns-nft?a=0xef2ee0bde0e21c3878ad2f74880d23763e9fd32b” total 302.

307 + 302 = 609.

In json “total” when requesting the link “htt ps://deep-index.mor alis.io/api/v2/0xEf2Ee0bde0e21c3878Ad2F74880d23763e9fD32b/erc20/transfers?chain=eth&limit=2” is also 609

P.S. I had to put spaces in the link due to restrictions

Hello, are you working on this? How soon will it be fixed?

Pinged devs again, it’s on our radar hope to get fixed this week

Devs said that the issue is solved here - can you confirm? Erc20 transaction in "/{address}/nft/transfers"

That question Erc20 transaction in "/{address}/nft/transfers" was about “/{address}/nft/transfers”. Current question is about “/{address}/erc20/transfers”.
There, the answer was that it was not clear what type the NFT or ERC-20 token had so the transaction is duplicated.
Here in “/{address}/erc20/transfers” writes NTF any transactions, even when “/{address}/nft/transfers” clearly defines the token as NTF.

Here’s a simple example at address 0x1E36A35F3a6b98491Ba7a3854cCbD0e83B8163de.
If we send a request to “/{address}/nft/transfers”, then we see that the Moralis defines PLUTO (PLUTO) clearly how NFT ERC-721, but at the same time making a request for “/{address}/erc20/transfers” we get both transactions ERC-20 and NTF PLUTO (PLUTO). And the paths “from_address” and “to_address” are the same from “/{address}/nft/transfers” and “/{address}/erc20/transfers”. That is, this is not the case when the transaction is in two directions.

Hello, have new information?

We are working on a solution. You should expect a fix within a day or two

1 Like

Hello, has the problem been resolved?

not yet, it’s being worked on, sorry for delay, we haven’t forgotten about this

Hi, is there any progress?

still on it, we will write here when its done

1 Like

Can you retry ? It should be good now

3 Likes

Hi I just checked and it looks like a solution! Thanks! If I notice an error in this request, then I will write

2 Likes