[SOLVED] ERC 1155 contract. URI fetched incorrectly

Hi all,

I am using Moralis for the development of a Dapp. You are constantly making changes to the service, which is great but since yesterday I experienced a strange behavior for the sync of my ERC 1155 tokens, which I never experienced before.
I am not sure if this a bug or the expected behavior, but whenever I mint a new token, the generic URI of the contract is synced instead of the individualized/calculated URI, as shown in the screenshot below:

After manually resyncing the individual token id with the respective API function, the URI is fetched as expected for this type of contract (I can only add one screenshot, so it will be included as an answer to this post):

Is that a bug or intended behavior? If intended, how can I get the correct URI directly in the beginning, respectively without the need to manually resync , since this would unnecessarily increase service consumption.

P.S.: I tested it with and without syncing the contract for NFT index, still the same result

Thanks in advance for your support.

Could you please mint a new NFT and see if this is still happening, and then leave it (don’t resync) if it keeps the base token_uri from the contract. This may have just been a rare case where the tokenId was not inserted into the base URI.

I already tried it a couple of times, still the same behavior. I even redeployed the contract two times:

To be clear: This only happens if the token id is minted the very first time. So a manual resync is currently at least doing the trick to force the correct behavior for future mints

thanks for reporting, we will investigate

1 Like

can you try again after 1-2 hours?

I will and after that post the result here. Thanks in advance

1 Like

it should be fixed now

1 Like

Works like charm now! Thanks for the quick fix!


1 Like