[SOLVED] Cronos syncing Contract EventLog

Hi there, i’m so exciting Moralis supporting the Cronos chain.
Appreciate that !
But I got some issue about syncing contract events.
I deployed same code in BNB chain and Cronos chain.
and add the same syncing about contract events for each chain.
But I only got the right data from BNB chain. The Cronos chain events is not show in my Class.

my server URL:https://wqr38xjsqwzy.moralishost.com:2053/server
The sync topic: CrossChainLog (address, address, address, uint256, uint256)
table name: CrossCRONOSTx
server type: cronos

not sure what I missed?

I think that we are still working on integrating Cronos

Hi @cryptokid ,
Just saw Moralis is supported cronos network today lol. So exciting to test it.
thank for reply info.I’ll wait for it. :slightly_smiling_face:

1 Like

It looks like it should work. Can you paste the server url?

Hope you got some events on the chain too

Hi @cryptokid
this is my server URL https://wqr38xjsqwzy.moralishost.com:2053/server
I try re-create again, but it still not work

Are you getting any events? With your example I can get one event synced to a server, although according to cronoscan, there should be two. Try restarting your server.

You can try things again soon once things have improved.

Hi @glad.yes, the Tx in cronoscan has two EventLog.I already restart my server ,but still get nothing.
not sure I missed something?

Here’s my sync for that contract.

Hi, @alex. I create a new server and I got one Tx too. But there are two Tx in this contract.
Not sure why just got only one Tx? and why old Server can’t get the Tx ? I compare the differences. the old server show Legacy. not sure is the reason that sync can’t work?

You can upgrade the old server from legacy to nitro.

you can find here how to upgrade:
in case that you have restricted CLP settings for tables, you should add coresercivrs role to CLP in case that it is not already set

Hi,@cryptokid , I upgrade the server from legacy to nitro and event works,thanks for help.
I saw the contract has two events , but I just got only one events.Is early period transaction are earlier than Moralis?

which of those two events is missing, that one from 20 days ago or that one from 17 days ago?

Hi @cryptokid,sorry for late reply.
can’t find 17days ago in event

Hi @cryptokid, sorry to bother you,did dev find the problem?

Hi, we are still working on cronos. It is not expected to work perfectly now.
I’ll try to test it today.

can you try again now?

Hi @cryptokid, sorry for reply late. I re-create sync event. It works perfectly. Thank you very much :slight_smile:

1 Like