[SOLVED] Connecting Ganache to Moralis

Cannot get Ganache to connect to Moralis. I am building an NFT marketplace following the 17 Moralis videos to clone Raribles.

I have installed Ganache and followed the instructions included in the Moralis View details to connect Ganache to Moralis and no luck and also followed the Moralis video and no luck: https://youtu.be/aRRS394is1U

Need some clarification on the Moralis server/view details:

  1. Download the version required depending on your hardware / os: https://github.com/fatedier/frp/releases

I downloaded and installed this package on my computer from Github: frp_0.38.0_windows_amd64.zip***

  1. Replace the following content in โ€œfrpc.iniโ€, based on your devchain

I replaced the data in the file frpc.ini with the data provided, the complete file looks like this:


server_addr = zywfdygwv1pf.usemoralis.com

server_port = 7000

token = HQwWVydJW0


type = http

local_port = 7545

custom_domains = zywfdygwv1pf.usemoralis.com


type = tcp

local_ip =

local_port = 22

remote_port = 6000

I then try to run this command:

frpc.exe -c frpc.ini

and get this error (There is no frpc.exe file in the folder, only a frps.exe).

frpc.exe : The term โ€˜frpc.exeโ€™ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

At line:1 char:1

+ frpc.exe -c frpc.ini

**+ ~~~~~~~~**

+ CategoryInfo : ObjectNotFound: (frpc.exe:String) [], CommandNotFoundException

+ FullyQualifiedErrorId : CommandNotFoundException



I used version frp_0.37.0_windows_amd64 and it had frpc.exe. Maybe you have an antivirus product that deleted it.

Thanks for the tip, the frpc.exe is part of the zip file when I unzip but once I run a dir on the folder, the file is deleted for some reason, must be something to do with virus protection, will investigate further.

Can you download frp_0.38.0_windows_amd64 and unzip it onto your computer, the reason the frpc.exe file keeps getting deleted from my Windows 10 computer is that Win 10 states the file has a virus or unwanted software and is deleted within 15 seconds from my computer.

I think that you can whitelist from scanning a specific folder

This file is infected with the Program:Win32/Uwamson.A!ml virus which is a form of malware/ransomware. Can this file be fixed?

it may not be infected, and only falsely detected that way.
You can download a previous version of fpr also, not necessarily the latest version.

Thanks, I stopped real-time security scanning and was able to load the most recent version of prpc. I now hit an issue with running scripts on my Win10 PC, any ideas?

PS C:\Users\Darren\OneDrive - Brickware\Documents\MORALIS\Projects\00> truffle init
truffle : File C:\Users\Darren\AppData\Roaming\npm\truffle.ps1 cannot be loaded because running scripts is disabled on this system. For more information, see about_Execution_Policies at https:/go.microsoft.com/fwlink/?LinkID=135170.
At line:1 char:1
+ truffle init
+ ~~~~~~~
    + CategoryInfo          : SecurityError: (:) [], PSSecurityException
    + FullyQualifiedErrorId : UnauthorizedAccess

there is a way to enable that in windows for powershell

Thanks, I got everything to work!

Hello, making progress and hit another snag with my moralis rarible clone project following the Moralis YouTube videos.

I am on part 6 of the videos and run the following commnand and cannot complete the migration.

PS C:\Users\Darren\OneDrive - Brickware\Documents\MORALIS\Projects\00\contracts> truffle migrate --reset

Compiling your contracts...
> Compiling @openzeppelin\contracts\token\ERC721\ERC721.sol
> Compiling @openzeppelin\contracts\token\ERC721\IERC721.sol
> Compiling @openzeppelin\contracts\token\ERC721\IERC721Receiver.sol
> Compiling @openzeppelin\contracts\token\ERC721\extensions\IERC721Metadata.sol
> Compiling @openzeppelin\contracts\utils\Address.sol
> Compiling @openzeppelin\contracts\utils\Context.sol
> Compiling @openzeppelin\contracts\utils\Counters.sol
> Compiling @openzeppelin\contracts\utils\Strings.sol
> Compiling @openzeppelin\contracts\utils\introspection\ERC165.sol
> Compiling @openzeppelin\contracts\utils\introspection\IERC165.sol
> Compiling .\contracts\MorarableToken.sol
> Compilation warnings encountered:

    Warning: SPDX license identifier not provided in source file. Before publishing, consider adding a comment containing "SPDX-License-Identifier: <SPDX-License>" to each source file. Use "SPDX-License-Identifier: UNLICENSED" for non-open-source code. Please see https://spdx.org for more information.
--> project:/contracts/MorarableToken.sol

> Artifacts written to C:\Users\Darren\OneDrive - Brickware\Documents\MORALIS\Projects\00\contracts\build\contracts
> Compiled successfully using:
   - solc: 0.8.0+commit.c7dfd78e.Emscripten.clang

Starting migrations...
> Network name:    'ganache'
> Network id:      5777
> Block gas limit: 6721975 (0x6691b7)


        throw new Error("Could not find artifacts for " + import_path + " from any sources");

Error: Could not find artifacts for Migrations from any sources
    at Resolver.require (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\resolver\dist\lib\resolver.js:60:1)
    at Object.require (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\index.js:172:1)
    at ResolverIntercept.require (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\ResolverIntercept.js:22:1)
    at C:\Users\Darren\OneDrive - Brickware\Documents\MORALIS\Projects\00\contracts\migrations\1_initial_migration.js:1:30
    at Script.runInContext (node:vm:139:12)
    at Script.runInNewContext (node:vm:144:17)
    at Object.file (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\require\require.js:94:1)
    at Migration._load (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\Migration.js:44:1)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Migration.run (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\Migration.js:217:1)
    at Object.runMigrations (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\index.js:150:1)
    at Object.runFrom (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\index.js:110:1)
    at Object.runAll (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\index.js:114:1)
    at Object.run (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\migrate\index.js:79:1)
    at runMigrations (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\core\lib\commands\migrate\run.js:76:1)
    at Object.module.exports [as run] (C:\Users\Darren\AppData\Roaming\npm\node_modules\truffle\build\webpack:\packages\core\lib\commands\migrate\run.js:44:1)
Truffle v5.4.28 (core: 5.4.28)
Node v16.13.1

you should create a new forum post for this problem, as it is not related to the original post