[SOLVED] Cloning Rarible: Prt1; Cant see any buttons

1st time using any of this web coding so forgive me.
I tried finding a possible answer and used the different ones mentioned in another post. (python -m https.server). Then in chrome used localhost:8000 ; didnt get anything but, the tab on top has (ArtProject

<button…). When i refresh i get this in virtual studio
::1 - - [20/Oct/2021 13:16:43] "GET / HTTP/1.1" 304 -

Also used “Open with Live Server” where i right click on the index.html under EXPLORER on left hand side in Visual Studio to open a browser. I also used “Open in Default browser”; both with same results no buttons.

I tried looking at the live server settings but honestly im not sure exactly what that would do.

you need a file named index.html in a folder, in that folder you run python -m http.server 86 (not https.server) and then you open in your browser You also need to have python installed for that command in order to work.

I think I do have it in a folder. you do mean a folder in virtual studio, left side under Explorer? I might be wrong but the tab v SIMPLE DAPP and under that is <>index.html and under that is JS main.js

I mean that you have to be in that folder where you have index.html when you run python -m http.server 86 and not in another folder.

nevermind i fixed that
ok im getting 3 problems
{} setting.json “C:\Users\name\Appdata…etc”
missing property “cer”[4,5]
missing property “key”[4,5]
missing property “passphrase”[4,5]

It works now or you still have some problems?

No im trying to figure out what you mean in that folder. i apologize.

. does that look right?

that looks right, what do you see in your browser when you access

this looks like a page, what do you have in that <body> tag?

Try to change:

<script type="text/javascript" src="./main.js"></script>

Does it show something if you comment the row with connecting main.js?

no, it looks the same in the web page as well

in the body tag

init = async () =>{
    window.web3 = await Moralis.Web3.enable();

initUser = async () => {
    if (await Moralis.User.Current()){

login = async () => {
        await Moralis.Web3.aunthenticate();
    }catch (error) {

hideElement = (element) => element.style.display = "none";
showElement = (element) => element.style.display = "block";

const userConnectButton = document.getElementById("btnConnect");
userConnectButton.onclick = login;

const userProfileButton = document.getElementById("btnUserinfo");

if you make a copy of index.html and name it page2.html and you remove all that javascript part from the end, you are going to see those two buttons when you access page2.html?

its not working. i had the boilerplate project JS from the getting started documentation working for connecting a wallet. The buttons for those worked. i think im gonna go that direction and see if i can figure out how to continue the cloning rarible tutorial from there. Thank you both for the help.

Ok im not sure what I did wrong but im sure i did something wrong. I followed the boilerplate project; that worked. Then started adding in different lines from the Cloning Rarible tutorial to see where there would be an error. Nothing went wrong and now im following the tutorial and its all matching up. Thank you for the help.