[SOLVED] CLI not installing

Hey im trying to install the moralis cli with this command : npm install -g moralis-admin-cli and this is what it gives me…can anyone help??

You can open your command line as administrator before running the command.

Hi please can you explain how to do that??

When you right click on command prompt, you can click run as administrator

Oh okay…how do you do that on mac??

If Mac, you need to add sudo infront of the command

Thanks got it! I now get this error saying the destination folder must include index.html. I have the build folder but what now?

If you have build folder, you need to cd build first before deploying

Is that a command you just run?

cd means change directory. I meant you need to navigate to the build directory in your terminal to run the deploy command

Okay so im in the build directory in index.html i run the command and get the same error…Sorry for bugging you like this…

Run this in your terminal rather

Same error

In the terminal opened in vs code here, you can cd build then run the deploy command

This is the root directory which isn’t a proper place to run the command

Sorry im confused…im new to this…

You need to do it one after the other

1 Like

THANKS SO MUCH!!! Got it!!!