[SOLVED] Can't connect to the Ganache server

Hi! I am enjoying the “I cloned Rarible in 24h” tutorials. As a dummy in development, I’ve been able to copy things so that they work so far. However, currently I am the Minting NFTs [PART 7] stage, and when trying to run frpc.exe -c frpc.ini command I get “Login to server failed: dial tcp 127.0.0.1:7000: connectex: No connection could be made because the target machine actively refused it.”

I have connected Ganache with Metamask, downloaded the frp file and edited frpc config with the content from Moralis Admin.

I tried to google and found some solutions to a similar problem, however I don’t have enough knowledge in development to effectively apply them for my specific situation.

Please help me with that :grinning:

Hi,
I was able to run this particular version of frp on windows:frp_0.37.0_windows_amd64 without problems.
You will need to allow it in firewall when it will ask you when starting it.

Can you share what you have in your frcp.ini file?

Hi @cryptokid, sure:

[common]
  server_addr = auuobw0qsb1s.moralisweb3.com
  server_port = 7000
  token = KkjrLSEQCW
[ganache]
  type = http
  local_port = 7545
  custom_domains = auuobw0qsb1s.moralisweb3.com

just tried to redo everything with the amd64 version and still got the same error message :cactus:

this is what I get as output for your configuration:

2021/09/02 08:53:04 [I] [service.go:304] [4ba7e646855ec8c6] login to server success, get run id [4ba7e646855ec8c6], server udp port [0]
2021/09/02 08:53:04 [I] [proxy_manager.go:144] [4ba7e646855ec8c6] proxy added: [ganache]
2021/09/02 08:53:04 [I] [control.go:180] [4ba7e646855ec8c6] [ganache] start proxy success
2021/09/02 08:53:06 [E] [proxy.go:797] [4ba7e646855ec8c6] [ganache] connect to local service [127.0.0.1:7545] error: dial tcp 127.0.0.1:7545: connectex: No connection could be made because the target machine actively refused it.

I get those errors because I didn’t start ganache, but it looks that you don’t get that far.

I get

2021/09/02 11:58:24 [W] [service.go:104] login to server failed: dial tcp 127.0.0.1:7000: connectex: No connection could be made because the target machine actively refused it.
dial tcp 127.0.0.1:7000: connectex: No connection could be made because the target machine actively refused it.

would it work if you disable windows firewall?

turned off and still the same result :frowning:

what version of frp you downloaded?
you can create a file named frpc_2.ini and copy there the contents, in case that you edited the wrong file and then run frpc.exe -c frpc_2.ini

1 Like

finally!

2021/09/02 16:43:56 [I] [service.go:304] [ef6f85c5d49322b4] login to server success, get run id [ef6f85c5d49322b4], server udp port [0]
2021/09/02 16:43:56 [I] [proxy_manager.go:144] [ef6f85c5d49322b4] proxy added: [ganache]
2021/09/02 16:43:56 [I] [control.go:180] [ef6f85c5d49322b4] [ganache] start proxy success

thank you so much mate! it feels good :grinning:

1 Like