[SOLVED] 403 unauthorized

Started with the rarity-ranking boilerplate. (highly modified)
Had it working for days. moved over to a live domain and cleared the user infos and had caused some sort of issue, was getting this:

"code":137,"error":"A duplicate value for a field with unique values was provided"

so i made a new instance, started fresh. uploaded the first of my nft-collections and all was good, login and displaying the collections worked
i began uploading the other two, simultaneously. and after that ive just been getting

error: "unauthorized" - from the response
-- in the page console
Failed to load resource: the server responded with a status of 403 ()

what happened? what do i need to do?

also I’m able to still update existing and add new classes to the instances with the backend generator/main.js, I’m just completely unable to access it via the dApp.

maybe you need to be authenticated
can you also share the server subdomain/url?

I changed nothing in the code to get this response, or in the instance.
it was working and then not working. and then same on the second instance. it was working and then suddenly locked out.
the application id and server are exactly the same as what i’m using to upload via the generator/main.js

on what request you get that error?
in your browser network tab do you have more info?
can you provide your Moralis Server subdomain?


the only info in the network tab is the 403 unauthorized
the prefetch OPTIONS request returns fine, this call fails every time for trying to ‘login’ user and as well as display anything out of the db’s

Also forgot to mention, that I tried a third ‘new database’ today as well. and that didn’t work at all. just had 403 error from the start. but like the others, i’m still able to upload from the backend.

maybe you didn’t set the right appId

The appId’s are correct in the .env that gets pulled into the index.js and within generator/main.js
and the appId is correct within the payload image

it looks like it has extra " that app id in that screen shot

I just noticed that as well, and am not sure as to why it coughed up issues now.
i just removed the quotes around the appId in the .env file and issue is gone.

i just assumed it was doing some weird string nulling on the backend… dang silly error thanks for walking with me through that.

looking at it more clearly, i see that it was escaping the quote i had ‘injected’